Problems with Odata and Octane

Hi

From one day to another, we are gettin some problems with odata querys

After setup everything like MF page said, we can connect till this part

if we select any of the options, we get the next error

the error appear in the C:\octane\log\octane.log too

2022-05-23 15:02:58 ERROR | Exceptions occurred in method: read(arg0=[{selectedFields=[activity_level, activity_level, blocked, blocked_reason, child_tasks, client_lock_stamp, closed_on,
comments, commits, covering_tests, creation_time, defect_root_level, defect_type, dependence, dependence_count, depends_on, depends_on_count, description, detected_by, detected_in_build,
detected_in_release, estimated_hours, fixed_in_build, fixed_on, has_children, has_comments, has_coverage, id, invested_hours, item_origin, last_modified, linked_items1, linked_items2,
milestone, name, ordering, owner, parent, phase, priority, product_areas, program, qa_owner, release, remaining_hours, reopens, requirements, run, run_step, severity, sprint,
story_points, tasks_number, taxonomies, team, test, user_tags, version_stamp, vulnerabilities, workspace_id] expandFields=[] filteredEntity=DefectEntityToken orderBy=[] groupBy=[] groupData=[] offset=null limit=1000 condition=[null] isWorkspaceAware=false}])
result entry #1 has thrown this: com.hp.mqm.infra.common.exceptionhandling.MQMServerException: entity 'com.hp.mqm.app.entities.entitytokens.DefectEntityToken' does not belong to the active
context!
Context=SHAREDSPACE : sharedspace=2001 : workspace=1001

in the C:\octane\log\nga\odata\odata.log nothing looks bad

2022-05-23T15:47:15,645 | WARN | CID: 9516olgyp0z50c2m8jpp2wmgv | Rest_Call_ID: k81jo0m4468m4tl0l6dd1w4xp | Global_Time: 2022-05-23T15:02:58.3281227 | Service: NGA | Thread: qtp299838951-12926 | System_IP: ServerIP | Client_IP: ClientIP | Client_Type: HPE_ODATA | Session: 1653313594625 | User: username| SSID: 4001 | WSID: 1001 | Server_Version: 16.0.300.70 | Method: GET | Duration(ms): 532 |  CPU(ms): 532 | DB(ms): 0 | DBWaitConn(ms): 0 | DBQueryCount: 0 | Status: 500 | URI: http://ServerIP :8080/odata/v4/shared_spaces/4001/workspace/1002/defects | END

I have re-search on google and I did not get any result

Could someone can help me?

Regards

Tags:

  • Verified Answer

    Hi

    Looks like you have made a mistake (easily made) with your ODATA url you are missing the 's' from the end of the workspace, this means you don't get any workspace level context once you actually try to access the data rather than just metadata. (I tried your mistake and got the same error)

    To make sure I am clear your URL should be:
    your-url/.../workspaces/1002/releases 

    While yours above (in the image) is missing the 's' of the workspaces.

    Fairly sure that once you get this right OData will work for you as designed.

    Thanks
    Daniel

  • you are right! thank you very much

    We have been using the same url in all our test. We thought it was  correct due to we get tables and we didnt focus/review more the URL.

    thanks you very much!