Validation failed while creating Jira Data Source

MFC Core did not had Jira connector. So, I dumped Jira connector in ...\Micro Focus\Connect\AppData\connectors\mfcConnectorJira folder. The folder contains following files. 

Now, In MFC, I can see Jira option to create one of the data source. So, I'm in 1st option of 4 steps to set up a data source.


In 1st step it is asking to enter Jira url:, password or API access token: *********.

now when I click on Next button, I get below error. I tried with API access token and my Jira password. and both resulted me in same error.

Note: In my enterprise, if Im launching my Jira url in a fresh (or lets say Chrome) browser, 1st I have to enter my SSO ID and its password, and email address ( and its password (not necessarily domain password).

I have mfcFullRestClient.jar that was pushed in to C:\Program Files\Micro Focus\Connect\Utilities on March 16, 2021.

Where do I start to resolve this please?

I'm in  MFC Jira Connector 4.4-HF5.819

  • Suggested Answer

    Hello - You need a native Jira account to act as the service account for Connect.  You can't use an SSO account in your data source as that authentication won't work over the Jira API. Also, if your Jira instance is Cloud, you need an API token in place of the password. Hope that helps!  

  • Hi Kelly, 

    thanks for the info. 

    Yes, Im very aware of your above statement. However, I have same error message with API. 

    Update: I got updated info about Jira instance that Im using in my enterprise is a Cloud based Jira but does not go through SSO authentication. 

    I also imported SSL certificate. 

  • Okay, can you confirm these things for me?  

    1. For Jira Data Source, URL is just set to:  with no additional characters after

    2. You are using your email address for the username field on the Data Source (since its Jira cloud)

    3. When you open a normal browser from that Connect server and go to the highlighted URL above, do you get a Jira login or your company login?



  • Please see below update.

    1) Yes, no space after "t" of .net

    2) Yes, Im using email address of the user in Jira Datasource

    User that im using in Jira Datasource has as its required permission in Jira. Example: can create any issue type in Jira.

    3) I get Jira Login if I have previously launched browser with SSO active session. But, if I launch Jira url in a new or fresh Incognito page, the page 1st lands in Company SSO page and after authentication of SSO, the page lands into Jira login screen. 

    Yes, this is where is the confusion and issue. 

    I stand by saying Jira is SSO enabled. and you may say the same But, the person who supports Jira instance in my Company says Jira is cloud and Not SSO enabled. that's where i wrote as "update" in my above comment even though originally I posted my Jira is SSO enabled. May be I have to debate internally?

  • Suggested Answer

    Yes, unfortunately that is where the problem lies.  Your Jira credentials are being routed through your company.  Maybe its not SSO, but some other type of authentication, but whatever it is, its not going directly to Jira which is where Connect is trying to authenticate directly.  Based on your statement, it almost sounds like your colleague thinks that because its Cloud it can't use some other authentication method?

  • Also, I just tested in Incognito browser as below. 

    Im in fresh incognito browser and typed in "gmail" and hit enter. The page routes to company SSO page and asked me to enter SOS credentials.  

  • Okay, so might be based on your machine login, or browser settings, etc.  Either way, I think you've found the problem.

Reply Children
No Data