No session when collecting information for IIS ASP.NET applications

0 Likes

Problem:

No session control window ( nmstart.exe) or session information for inetinfo.exe when I check "collect information for IIS/ASP.NET applications".

Resolution:

A: This article is for 7.0.x release of DevPartner Studio (DPS).

A few things to look at:

1. No terminal services such as VNC, PCAnywhere etc. used.

2. One of our tools called Distributed Analysis is disabled at that moment when you try to profile inetinfo.exe or any components running under it:

Run the command DAEnabler.exe from:

[Root]:\Program files\Compuware\DevPartner Studio\Distributed Analyzer\DAEnabler.exe /state

If it is enabled, run DAEnabler.exe /disable to disable it.

3. Make sure that IIS service can interact with the desktop:

Go to Services, right click on IIS admin , go to its properties =>Log on tab, make sure that 'allow service interactive with desktop' is checked.

4. IIS configuration is appropriate:

1). Visit the Internet Information Services Snap-In in MMC.exe. This snap in is usually located here: c:\winnt\system32\inetsrv\iis.msc.

Once you open the iis.msc snap-in, go to the Default Web Site location, and ensure the settings are:

a. Home Directory Tab:

Application Protection: Low (IIS Process)

Execute Permissions: Scripts and Executables

Also, click on the 'Configuration' button, go to 'App Debugging' tab, under 'Debugging Flags', make sure that 'Enable ASP server-side script debugging' is checked. if you want to get client side info, check 'Enable ASP client-side script debugging' too.

b. Web Site Tab:

Connection Timeout: (if you get any timeouts, increase this value to double or triple what is normal for your program).

Now go down to your virtual web site. Right click and go to properties and ensure your settings are like so:

a. Identity Tab: Set to Interactive User

b. Virtual Directory Tab: Application Protection: Low (IIS Process)

Execute Permissions: Scripts and Executables

5. Check the "collect information for IIS/ASP.NET applications" setting from Performance settings.

If you still can't get session control window for Inetinfo.exe, please use an utility called Listdlls.exe against inetinfo.exe You can download this utility from the following website: http://www.sysinternals.com

On the command line, type:

Listdlls.exe inetinfo.exe

And see if you can find a component called "NMISAPI.DLL" is in the output or not. If NMISAPI.DLL is not there, please :

1. Check to see if NMISAPI.DLL is installed correctly:

By default, it should be under

[root]:\Program files\Compuware\DevPartner Studio\Analysis

2. Use regsvr32 to re-register this component.

After this, retry profiling.

Old KB# 11257
Comment List
Anonymous
Related Discussions
Recommended