Can't see source code in SoftICE

0 Likes

Problem:

I want to debug debug my NetOs32.DLL. I load the module from SoftICE. The load is succesful. When I translate this DLL, SoftICE prompts for the location of source code for system libraries such as abort.c

SoftICE does not ask for the location of the source files of NetOs32.DLL.

When breakpoint is hit, assembly source is displayed and also without the name of the functions or globals (as in free build). I do a 'stack', the name of the most frequent function (invoked from the netos32), is not displayed, only the offset from the base address is displayed (as if the DLL has been stripped of the debug symbols).

Resolution:

If you are using VC5.0 then make sure that you UNcheck "Separate Types" option under Linker tab of project settings (command line option is /PDBTYPE: and we need CON, not SEPT).

If this is not the case, then change the setting for Symbol Loader's translation such that (1) it will "package" the source files to NMS file and "prompt for missing file". If symbol loader doesn't prompt for missing files, then it is not a debug version (or the debug version that Symbol Loader is seeing does not contain line number/source information).

Finally, type table in SoftICE.  Is the highlighted table your module?  If not, switch to that module, then re-try unassembling.

Old KB# 11740
Comment List
Anonymous
Related Discussions
Recommended