Avoiding unrecoverable keyboard lockups on NT caused by SoftICE

0 Likes

Problem:

I'm trying different i8042prt.sys drivers on NT 4 in order to get SoftICE to work with my configuration. I must have SoftICE load at boot and/or system time.However, my keyboard locks up as soon as NT is started and I am unable to log onto NT to try another driver.

Resolution:

There are many ways to avoid this situation. Having a dual boot configuration and/or booting from a floppy lend themselves as promising possibilities.

However, if your %systemroot%\system32\drivers partition is NTFS, the you will not be able to access the necessary drivers to either disable SoftICE, or swap the keyboard driver out. In this case the following solution is preferable:

Set up your system to temporarily bypass the Logon prompt.To configure this using the registry, edit:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\Winlogon

Set the DefaultDomainName, DefaultPassword (must be non-blank), and DefaultUserName. Set AutoAdminLogon to 1 (all are type REG_SZ). If you ever want to logon as a different user, hold down the shift key as you logoff.

Make sure that HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\DontDisplayLastUserName is set to 0 (false)

Setup a shortcut on your desktop that you can double click on if the keyboard driver patching fails which either renames NTICE.SYS, or merges a registry file which forces NTICE to load as a manual driver (start mode 0x3). The registry key that controls this is HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services tice\Start

Optionally, you can create a shortcut to save the SI command window to a log file which may be useful for our Driver support engineers to track down the root of the problem. A shortcut which achieves this should execute a command similar to NMSYM /log:softice.log

When you reboot you should have your keyboard control back & be able to try another troubleshooting step.

Old KB# 11063
Comment List
Anonymous
Related Discussions
Recommended