Using BoundsChecker Instrumented Builds with the Windows CE x86 Emulator

0 Likes

Problem:

I am producing a Windows CE application, debugging it using the CE x86 emulator.  As soon as I enable Instrument Builds, I get a "cannot open file kernel32.lib" during the final program link stage.

Resolution:

You can eliminate this error by following these steps:

1) From VC, go to Tools | Options.

2) Select the Directories Tab.

3) The third drop down list reads "Show directories for:".  Click on this and select "Library Files".

4) Double click in the space immediately under the last listed path in the big list box.  You'll see a browse button appear to the right of where you clicked.  Click on the browse button and navigate to the directory which includes 'kernel32.dll'.  It should be nested in your VC folder (default path: c:\Program Files\DevStudio\VC\lib).

5) Click OK, save your settings, then clean and rebuild your project.  It should run in x86 emulation mode at this point.

6) If this works, you can save this setting globally by following these same steps without opening a project in VC .

Old KB# 12239
Comment List
Anonymous
Related Discussions
Recommended