BoundsChecker TrueTime and TrueCoverage do not allow the H compiler option.

0 Likes

Problem:

Whenever I try to build my project which is using the /H compiler option (whether I build with your products or not) the build fails with LNK1104: cannot open file.

Resolution:

Typical failure output:

Deleting intermediate files and output files for project 'stltest - Win32 Debug'.

--------------------Configuration: stltest - Win32 Debug--------------------

Compiling...

Usage: NMCL CL-options NMCL-options source-file(s)

NMCL-options:

/NMhelp

/NMignore:source-file[:function]

/NMonly:source-file[:function]

/NMopt:option-file or <A>/NM@option-file

/NMlog:log-file

/NMpass

/NMstoponerror

/NMclpath:cl-path (directory or complete pathname)

/NMbcpath:bc-path

/NMttpath:tt-path

/NMnogm

/NMbcOn (Assumed. Cannot be specified concurrently with NMttOn)

/NMttOn (Cannot be specified concurrently with NMbcOn or NMtcOn)

/NMtcOn (Cannot be specified concurrently with NMttOn)

/NMttNoLines (Cannot be specified concurrently with NMbcOn)

/NMttInlines (Cannot be specified concurrently with NMbcOn)

Linking...

LINK : fatal error LNK1104: cannot open file ".\Debug\stltest.obj"

Error executing link.exe.

stltest.exe - 1 error(s), 0 warning(s)

In this specific case I'm using /H512 in my project options.

Unfortunately, there's no real workaround for this other than to remove the /H compiler option from your projects, or uninstall the Compuware product in question. This problem is currently under review and should be corrected in coming versions of the products. (As of right now, the problem exists in BoundsChecker v6.03, TrueTime 1.22, and TrueCoverage 1.22, though for the last two products, normal VC builds work normally.)

Old KB# 11119
Comment List
Anonymous
Related Discussions
Recommended