FAQID1702 - Using the SoftICE Debugger in a Virtual Machine

0 Likes

Problem:

When I using the SoftICE debugger in a VMWare virtual machine, the guest operating system hangs. How can I work around this problem?

<!--- END INSERT QUESTION --->

Resolution:

If you plan to use SoftICE in a virtual machine, open the configuration file for the virtual machine in a text editor and add the following two lines:

vmmouse.present = FALSE

svga.maxFullscreenRefreshTick = 5

Otherwise, your mouse and screen may become unresponsive when breaking into the SoftICE debugger, making it appear as if your guest operating system has hung. svga.maxFullscreenRefreshTick can be set to any value greater than 0. Lowering the value of svga.maxFullscreenRefreshTick increases the responsiveness of SoftICE, but it also has a negative impact on the performance of the guest operating system when SoftICE is not running. We recommend removing or commenting out these configuration options when you are not using SoftICE.

Sometimes, even with these configuration options, pressing Ctrl-D does not display the SoftICE window and your mouse and screen appear unresponsive. Exit SoftICE by pressing Ctrl-D again, then use SoftICE in VGA mode as explained below.


  1. Open a command prompt (for instance, choose Start > Run, type cmd and click OK).
  2. Press Alt-Enter to enter VGA mode.
  3. Press Ctrl-D to enter SoftICE.

This was taken from an article on the VMware support site.

Old KB# 11072
Comment List
Anonymous
Related Discussions
Recommended