Weblogic 8.1 and JRocket 1.4.2_05

0 Likes

Problem:

How to get DPJ to work with WebLogic 8.1 and jrockit 1.4.2_05

Resolution:

Weblogic 8.1 comes with jrockit 1.4.2_04 and DPJ does not support that version. DPJ supports jrockit 1.4.2_05

1. Install JROCKIT 1.4.2_05 into a root

directory...e.g.C:\jrockit-j2sdk1.4.2_05

2. In your Weblogic Domain created, modify the setDomainEnv.cmd file

the following way:

Modify the following JAVA_HOME entries for jrockit...

if '%JAVA_VENDOR%'=='BEA' (

set JAVA_HOME=C:\bea\jrockit81sp3_142_04

) else (

if '%JAVA_VENDOR%'=='Sun' (

set JAVA_HOME=C:\bea\jdk142_04

) else (

set JAVA_VENDOR=BEA

set JAVA_HOME=C:\bea\jrockit81sp3_142_04

)

)

To the following.....

if '%JAVA_VENDOR%'=='BEA' (

set JAVA_HOME=C:\jrockit-j2sdk1.4.2_05

) else (

if '%JAVA_VENDOR%'=='Sun' (

set JAVA_HOME=C:\bea\jdk142_04

) else (

set JAVA_VENDOR=BEA

set JAVA_HOME=C:\jrockit-j2sdk1.4.2_05

)

)

Old KB# 11189
Comment List
Anonymous
Related Discussions
Recommended