SoftIce nt causes crash.

0 Likes

Problem:

Stepping through KiIdleLoop, an attempt to step over HalProcessorIdle ALWAYS results in either SoftIce internal error or kernel mode fault (SoftIce breaks in KeBugCheckEx) with an error which seems to be random:

Resolution:

This is a known problem that results from simultaneous INT 1s being executed on SMP machines. The only way around this is to turn off the automatic context switching that SoftICE performs. This can be done by envoking the SET THREADP OFF command from the SoftICE command window. This problem only manifests itself if you are stepping through the IDLE loop on an SMP machine. Otherwise, you should never see it.

Old KB# 12124
Comment List
Anonymous
Related Discussions
Recommended