Troubleshooting SERIAL and SERIAL32

0 Likes

Problem:

I cannot get SERIAL/SERIAL32 to work properly on my system for remote debugging. Do you have any suggestions on how to troubleshoot this utility?

Resolution:

If you cannot get SERIAL or SERIAL32 to work on your system, please be sure that you have read the SoftICE manual on how to setup your two PCs and then please check the following:

* Check that your NULL modem cable has the EXACT same pin layout as described in the SoftICE manual.  There are a few kinds of NULL modem cables and only the one listed in the SoftICE manual will work.

(note: the latest version(s) of SoftICE only need the modem control signals when you're actually using the modem and/or SERIAL.EXE for DOS - machine to machine connections using SERIAL32 can be made with just 3 wires [GND, TxD and RxD]).

* Make sure you are using either COM1 or COM2. You cannot use COM3 or COM4, as doing so will hang the system.

* If Windows is using the COM port, try disabling it via the OS Control Panel. Windows and SERIAL/SERIAL32 cannot both be using the COM port.

* If possible, use a program such as HyperTerminal to verify that the two PCs can communicate with each other.

* Under Win95/Win98, make sure you've reserved the appropriate COM port using Loader32/Edit/SoftICE Initialization Settings/Remote Debugging/Serial Connection (not necessary under Windows NT).

* Under Win95/Win98, if your COM port is mapped to standard device I/O address, make sure it is using the correct IRQ. You can find this out from the SYSTEM icon from the Control Panel. Windows 95 can accidentally re-configure this setting with its Plug & Play logic.Users have reported to us that by disabling the Plug & Play OS in the BIOS, they have been able to get SERIAL/SERIAL32 to work on their systems.

* Under Win95/Win98, a COMx=ON line must still be specified in the SoftICE WINICE.DAT file for remote debugging to work properly. X represents a port number.

* On the remote machine, make sure SERIAL.EXE enters a "Waiting for SoftICE" state.SERIAL.EXE must be in the "listen" mode. (note that SERIAL32 does not have such a message)

* Have you tried to issue the "SERIAL ON" command from the SoftICE? If you can't see the screen, try "blind" typing this command. You may want to put the "SERIAL ON" command line into the WINICE.DAT file as part of the INIT string. You can do this via the Symbol Loader by going to EDIT | SoftICE Initializations Settings...

* Are you specifying a baud rate at command line? If so, try not doing so and let SoftICE and the SERIAL utility do the hand shaking automatically.

* Are you running SERIAL.EXE utility in Windows DOS box? If possible, run SERIAL.EXE in a pure DOS environment (e.g. DOS 6.22), or use SERIAL32.EXE instead.

Old KB# 11056
Comment List
Anonymous
Related Discussions
Recommended