BoundsChecker for DOS Causes Data Loss in Serial Communication Programs.

0 Likes

Problem:

Running my serial communication program under BoundsChecker for DOS results in some characters being lost.  Is there a workaround for this?

Resolution:

To configure BoundsChecker for DOS for maximum performace, try the following:

1. If using Borland, enable both performance options.

2. Disable Verbose Data and Line options. If problems persist, disable all data checking.

3.  If using Microsoft, link in BC4.OBJ. If using Borland create a 4K buffer at the beginning of your data segment.

4.  Use the lowest baud rate possible in your serial program.

5.  Remove all unnecessary drivers and TSR's; one user reported that removing 386MAX dramatically improved his communication rate.

6.  Use the fastest machine available.

7.  If possible, use a UART with a FIFO buffer chip.

Old KB# 12181
Comment List
Anonymous
Related Discussions
Recommended