My machine becomes low on virtual memory when using BC in the IDE.

0 Likes

Problem:

I try to debug an app in IDE with BC enabled, and if I leave it on a break point, I get a 'system is running low on resources' message.  What gives?

Resolution:

BoundsChecker can gather a great deal of information, depending on the options you have set.  The IDE is memory-intensive as well.  At times, the demands on your system can be quite significant.  To minimize this impact, increasing the size of your paging file (try 2 to 3 times RAM, at least) may provide temporary relief.  Another option is not only build portions of the application with debug, and/or use the modules and files tab to remove modules from consideration. (To do this, go to the modules and file tab, manually add the module, then unclick it.) The most common cause of this is running a large application in BC with the "Collect and Report Program Event Data" item checked on the Event Reporting tab of BC Settings. This can QUICKLY swallow disk space as well. If you are seriously concerned about space/memory, selectively use this option.

Old KB# 12191
Comment List
Anonymous
Related Discussions
Recommended