Unable to run "upgrade all"

I've been testing Dimensions 14.5.2 and Oracle 12c R1 on a test Server 2016 and it's all looking very good.

I decided to test on Server 2019 using the same exact steps I used on 2016. There were no issues, just like with Server 2016.

I run dmdba system/[password]@Oracle12c, and I'm in just like it's supposed to.
Then I run upgrade courseware /force, and I get...

SYSTEM> upgrade all /force
Error: cannot determine Dimensions node
Ensure user 'system' has the DBA role or the 'SELECT ANY TABLE' privilege

I can't find anything online and I'm not an Oracle/Dimensions pro and I'm at a loss as to what to look for, hoping there may be some ideas.

  • Verified Answer

    I would start with this article from our knowledgebase: http://knowledgebase.serena.com/InfoCenter/index?page=content&id=S132704&actp=search&viewlocale=en_US&searchid=1617301496647

    I know the article was written for Dimensions 10.x, however, this has not changed much. 

    If that doesn't solve it, can you tell us how the base database and the pcms_sys database were copied/cloned into the Oracle instance you are using with this latest upgrade attempt?  I don't really think this is the difference in Operating System for Dimensions -- most likely the database was not copied or setup the same way.

  • Thanks.

    I'm ultimately going from Dim v10/Oracle v10g > Dim2009r2/Oracle 11g > Dim14.5.2/Oracle 12c. When I originally imported everything, it was successful for pcms_sys.

    On the first step, runnning pcms_sys/pcms_sys@Oracle12c gives me ERROR: ORA-01017: invalid username/password; logon denied

    To remove and readd, should I do this in sqlplus?

    drop user pcms_sys cascade;
    create user pcms_sys identified by pcms_sys default tablespace PCMS_data temporary tablespace PCMS_temp;
    grant dba,connect,resource to pcms_sys;

    Then this?

    imp file=dim11export.dmp fromuser=pcms_sys log=dim12import.log
    dmdba system/[password]@Oracle12c
    upgrade pcms_sys /force
    then run VRS

     

  • This was the original script importing on both servers...

    create user PCMS_SYS identified by PCMS_SYS default tablespace PCMS_data temporary tablespace PCMS_temp;
    grant dba,connect,resource to PCMS_SYS;
  • When you perform the import, the pcms_sys user will now have the pasword from the source database, the database where you performed the export.  This is probably why you get the authentication error logging in.

    If you are missing grants, it may be the export or import statement is not including them, it may be that your new basedb (schema) has a new name that is different from the source.  This is why you may need to grant the access to the pcms_sys tables/views.  I don't do much import/export with Dimensions these days, but I usually omitted the grants from my exports -- it just took too much time with the Oracle utilities to process grants and I could replace them so much faster with the statements in the Knowledgebase article referenced earlier.

    I'm not certain I understand what the problem or question is here.  There are many ways to copy data, not certain we have a recommended method.

  • Uh, I figured out the issue.

    The process was right, but I used a dmp file I was testing with which only had one thing in it and it didn't include pcms_sys. Face palm tone3

    I got an export with ALL the data and now I'm back in business lol.

    Thanks for helping.