Date field in email notification is offset by -10 hours


Hi,We are experiencing an issue where email notifications which contain date fields are incorrect and is usually offset by -10 hours. For example, user enters 10/28/2014 12:00:00 AM for "Est Date" but the email notification delivers it as: Est Date: 10/27/2014 02:00:00 PM. This has just recently started happening but I'm not able to figure it out. I've edited User Profile>Time Zone to (GMT - 10:00) Pacific/Honolulu but email still sends the date wrong. Any suggestions what could be wrong? Thanks in advance!
Parents

  • J / Damon,You might want to try putting debug messages in the Javascript (one for the change of the field, and one for the submit callback) and also in an Appscript that would run from the Notification event and post the value of the field to the Application Event Viewer. That way you can trace the values through the life of the transaction and see where it is being offset.if it is intermittent, then it may be a SBM defect. I would approach Serena Support with a case and search the KB to see if it has been posted as a defect.Regards,Bill
Reply

  • J / Damon,You might want to try putting debug messages in the Javascript (one for the change of the field, and one for the submit callback) and also in an Appscript that would run from the Notification event and post the value of the field to the Application Event Viewer. That way you can trace the values through the life of the transaction and see where it is being offset.if it is intermittent, then it may be a SBM defect. I would approach Serena Support with a case and search the KB to see if it has been posted as a defect.Regards,Bill
Children
No Data