Citrix Client Selective Trust and LR 12

Hi all,

i have recorded a script that connect to a citrix application. When i made this connection manually the citrix receiver ask me with the client selective trust the permission to access to local file, i check the don't ask me again and get full permission and everything is ok. But when i run my script the Client Selective Trust popup come every time and there is no check for never ask me again so every time i run the script i need to manually give the permission. I add that even if i don't allow the access to local file the script run correctly , the real problem is the popup. I can't run a stress test if i need to answer manually. I have also made all the citrix best practices with registry key but seems that loadrunner bypass the system rules. Can anybody halp me?

 

 

Thanks and sorry for my english

 

Best regards

 

Cesare

  • Hi Cesare,

     

    Please ask Citrix admin to modify registry settings.

    You can find detailed information from the link below

     

    http://support.citrix.com/article/CTX133565

     

    Best regards,

    Mikhail

  • Hi Mikhail,
    I have alredy applied this best practice but doesn't work for me. When i set local machine registry key for the client selective trust of ICA client My script fail the execution with Last citrix error=70(error connecting to the server). So i delete the key and everything work, except for the popup that Is really annoying me.

    But thanks for the reply
  • Cesare,

    Did you ever get past this issue? I'm running into the exact same thing. 

    It looks like the HP ICA client is crashing. I found a crash event in the Windows Event Veiwer.

    Faulting application name: HP.Utt.StandaloneDebugger.exe, version: 12.53.185.0, time stamp: 0x56efaacd
    Faulting module name: combase.dll, version: 6.3.9600.18666, time stamp: 0x58f317cc
    Exception code: 0xc0000005
    Fault offset: 0x0001b0df
    Faulting process id: 0xc7c
    Faulting application start time: 0x01d301cebe46a265
    Faulting application path: C:\Program Files (x86)\HP\LoadRunner\bin\HP.Utt.StandaloneDebugger.exe
    Faulting module path: C:\Windows\SYSTEM32\combase.dll
    Report Id: 0bfc633a-6dc2-11e7-80cd-000d3a10b8b3
    Faulting package full name:
    Faulting package-relative application ID:

    I also played around with the Client Selective Trust registry settings and found that if I rename the "oidTrustedSitesRegion" key to "oidTrustedSitesRegionX", the client continues to function, but does not bypass the permissions dialag as desired.

    Anyway, I'm hoping you got past this, remember the fix/workaround, and still participate in this forum.

    Thanks!!!