LR 12.01: Correlation scan failed due to parsing errors

Hi,

 

I am evaluating the LR 12 for my client.

 

The script that I have to create for a CRM application is very large- just to record the whole script it takes about 1  hour!

 

(It contains about 20 forms to fill out and submit)

 

After recording, my VuGen starts to generate the code and correlates dynamic parameters according to the rules that I have created previously.

 

It takes more than 30 min (too long) ...and finally ...it fails to correlate and displays an error message:

 

One of the post-generation procedures has failed.
Failed procedure: Performing scan for correlation post generation operation.

 

Correlation scan failed due to parsing errors. Fix the errors and click Design Studio to scan correlations.

 

Taking a look into the generated code I found that same of the code are corrupted: like broken lines etc.

After that the resulting code became unusable and I have to re-record my script and getting the same error message over and over again!

Among 7-8 attempts to record the script only 1 maybe successful.

 

 

Can anybody tell me why it happens and how to overcome this problem?

 

Appreciated any help and advice!

 

Parents
  • after recording the script in vugen i got " ne of the post-generation procedures has failed.
    Failed procedure: Performing scan for correlation post generation operation".in vugen 12.55

    how can i resolve this error.please find screenshot.

  • Instead of re-record the corrupt script , you can regenerate it again

    ( you will get script same as after first recording )

    You can also regenerate the script with 1 rule each time to understand which rule causes corruption.

    I believe that some rule from LR  11.00 causes this issue.

    On regenerate options -> Correlation -> Configuration you can also limit the length of the value to make the correlation more accurate  

     

Reply
  • Instead of re-record the corrupt script , you can regenerate it again

    ( you will get script same as after first recording )

    You can also regenerate the script with 1 rule each time to understand which rule causes corruption.

    I believe that some rule from LR  11.00 causes this issue.

    On regenerate options -> Correlation -> Configuration you can also limit the length of the value to make the correlation more accurate  

     

Children