manual correlation

hi masters,

 

quick help on the LB and RB underneath is the value data that i want to capture

 

sessionState="
0.0000000181e8fc139bf38648b66cbcff087f7512642a22e89a9308445ea38b8f5aa12d704a6e8394e5674015a3da9087e5325f9cad0b71a63a2a711bb11c61c75535e21bee47c21994c2562bbe52777f198ce903c74cb9b98f9411640d46977954ebe7e20e316ec8028f5f5f904b34d5edf14bb8ff5e46d5a8ee8c0d722560bcbc17997950a715d87e17b5729a0c4ebf54e3b7c032aff3230e4d.1033.1.2.America/Shiprock.pxs*_1*_ul*_2*_sp*_2*_upriv*_1*_uf*_1*_itp*_1*_prun*_3*_pal*_1*_itu*_1*_prup*_1*_up*_1*_itup*_1*_upp*_1*_sdip*_15*_pf*_1*_df*_1*_upl*_2*_pl*_1*_pp*_1*_prjInst*_1.0
.1.1.Fuel Reporting.D9C13DD04234E4AA7E1C3D86FD459F97.0-0.1.0_-0.1.0_-1033.1.1_10.1.0.*0

 

so here is my correlation piece

web_reg_save_param("session_stateA", "LB=sessionState= ' ", "RB='; ", "Notfound=warning" ,LAST);

when i rerun my script i get this message:

 

Action.c(377): Warning -26377: No match found for the requested parameter "session_stateA". Check whether the requested boundaries exist in the response data. Also, if the data you want to save exceeds 5000000 bytes, use web_set_max_html_param_len to increase the parameter size   [MsgId: MWAR-26377]

 

my web_set_max is already (web_set_max_html_param_len("5000000")

 

thanks in advance

Parents Reply Children
  • Is the RB that you mentioned in the correlation statement is also correct?

    If yes, what is approximate maximum length of sessionstate?
  • What all you need to do is correct your RB & LB and check on ORD as well. There might be multiple instance occuring with RB and LB what you will put.

     

    To eleminate ORD make sure your RB & LB are unique. I dont think you have any issue with param length size.

     

    I hope you are trying to keep the correlation code on top of right request. Just double check on this as well.

     

    Thank you.

     

     

  • but on this example would you might letting me know what would be the correct LB and RB?

     

    thanks

  • Verified Answer

    Assuming you're trying to capture from a source that looks like this:

     

    sessionState=" 0.0000000181e8fc139bf38648b66cbcff087f7512642a22e8​9a9308445ea38b8f5aa12d704a6e8394e5674015a3da9087e5​325f9cad0b71a63a2a711bb11c61c75535e21bee47c21994c2​562bbe52777f198ce903c74cb9b98f9411640d46977954ebe7​e20e316ec8028f5f5f904b34d5edf14bb8ff5e46d5a8ee8c0d​722560bcbc17997950a715d87e17b5729a0c4ebf54e3b7c032​aff3230e4d.1033.1.2.America/Shiprock.pxs*_1*_ul*​_2*_sp*_2*_upriv*_1*_uf*_1*_itp*_1*_prun*_3*_pal*_​1*_itu*_1*_prup*_1*_up*_1*_itup*_1*_upp*_1*_sdip*_​15*_pf*_1*_df*_1*_upl*_2*_pl*_1*_pp*_1*_prjInst*_1​.0 .1.1.Fuel Reporting.D9C13DD04234E4AA7E1C3D86FD45​9F97.0-0.1.0_-0.1.0_-1033.1.1_10.1.0.*0";

     

    Then your web_reg_save_param should look like this:

    web_reg_save_param("session_stateA", "LB=sessionState=\"", "RB=\"", "Notfound=warning", LAST);

     

    Any time you're searching for something in double quotes ("), you have to escape out the quotes with a backslash.

    If you still don't get anything, try just looking for "LB=sessionState", "RB=;", or whatever stamdard characters you see, and narrow it down from there.  It's not unusual to find hidden characters in the data, but those hidden characters (like tabs, carriage returns, etc) will show up as escaped characters in the param value when you have param logging enabled.

     

    I wouldn't worry about setting your  ORD until you capture at least 1 item first.

     

    Another helpful hint is you can approximate your byte size in your web_set_max_html_param_len command to roughly however many characters you need (ie: 8000 characters =~ 8000 bytes).  5,000,000 is plenty enough, but at some point you'll want to scale that down to reduce the memory footprint of your script when you run it.

     

    Good luck.

     

    EDIT:

     

    One more thing!  Make sure you're trying to capture this data from the right request.  If you're in doubt, you might try cranking up your logging to display "Data returned by server" and verify that the response you're trying to capture occurs as a result of the request immediately following your web_reg_save_param call.