TruClient: incoherence between VuGen and Develop Mode

Hi everyone, 

I've a particular problem with a TruClient script: if I execute it in Develop Mode (so in graphic mode) the navigation is Ok, but if I run the same case in VuGen Log mode or by a Controller through some generators the script failed with the error message below

    Click on Ok button ** failed - target object was not found
There's an incoherence between the result provided with the Develop Mode and the VuGen execution.
Thanks for collaboration, 
  • Hi Lorenzo,
    The error message indicates that when TruClient tried to click the "Ok button" object, it was not able to find it.
    The possible reasons vary: The page is rendered differently in the browser or the page has not fully loaded when TruClient was trying to access the object.
    I'd suggest to first review the error snapshots and, if needed, add snapshots for each step (set snapshots to "Always"), to understand the application behavior in the non-interactive replay and to modify the script accordingly (add wait steps, modify the object identification etc.).

  • Hi, thanks so much for the response. 

    I've tryed to set the snapshot's level to "Always" and "On error" but the images are about the Develop execution, so there isn't an evidence of the error because in interactive mode the run finished fine. Also I've insered many wait and make some times the "Replace" option on the indicted button but the results is the same: the run failed in VuGen/Controller mode and is Ok in Develop Mode. For instance, the error stay in logout fase. 

    Below, an image of the button that caused the error: it's about a logout popup. 



    Can you have another idea?

    Best regards, 


  • I've resolved the problem changing the identification of the button object in "Java" mode: now the navigation can continue both in Develop and VuGen mode. 

    Thanks for the support,