Issue with IE11 - True Client Protocol : multiple browser windows

Hi All,

I am new to LoadRunner and True Client Protocol. In our application we have a scenario like.. After clicking some button a new window opens have to capture the time taken to load that new window..here in IE11 with true client protocol new empty tab is opening while recording and reply once I click the button. so here I am unable to check whether the required window is loaded or not,

it works for chrome .. seems some settings issue for IE11.

Could you please help me on this.

Thanks,
Khaja Shaik.

 

  • Hi,

    Can you please attach a screenshot of the behavior in Microsoft IE 11 and the behavior in TruClient IE?

    It will help clarifying what the issue is so we can advice how to overcome

    Regards,

    Shlomi

     

  • Hi Shlomi,

    Thank you for the quick help.

    Please find the attached screenshots.

    Behaviour in IE11:

    1. Here to activate a CA, user clicks on ‘Activate CA’ button, please refer the image Test1.png

    2. New window will open as below, after clicking on ‘Activate CA’, please refer the image test2.png

    3. Complete new window, please refer the image test3.png

    Behaviour in True Client IE:

    1. Please refer to the image test4.png

    2. New window is not opening, empty blank tag is getting opened as shown in test5.png

    Could you please have a look once and let us know if more info is required.

    Regards,

    Khaja Shaik.

     

     

  • Hi Khaja,

    Can you please make sure the application is in the Trusted security zone in Microsoft IE and then try again?

    If it didn't help, which is very likely to be the case, can you please run the script until the point it supposed to click on "Activate CA". Stop it. Disable standards enforcement from the Advanced menu of TruClient browser and then manually click on the "Activate CA" button (not through replay). Is there any difference in the behavior? 

    Please open support call in parallel to this post

    Regards,

    Shlomi

     

  • Hi Khaja,

    Can you please make sure the application is in the Trusted security zone in Microsoft IE and then try again?

    If it didn't help, which is very likely to be the case, can you please run the script until the point it supposed to click on "Activate CA". Stop it. Disable standards enforcement from the Advanced menu of TruClient browser and then manually click on the "Activate CA" button (not through replay). Is there any difference in the behavior? 

    Please open support call in parallel to this post

    Regards,

    Shlomi

     

  • Hi Shlomi,

    Thank you for the quick help. I will try the same

    Could you please provide us Skype ID, so that I will schedule a support call.

    Regards,

    Khaja Shaik. 

  • HI Khaja,

    You need to login to the support site here https://softwaresupport.hpe.com/ using your support sign-in and open a ticket after you signed in. If it is unclear use the Chat link on that page to understand how a support ticket should be opened.

    Regards,

    Shlomi

     

  • HI Khaja,

    You need to login to the support site here https://softwaresupport.hpe.com/ using your support sign-in and open a ticket after you signed in. If it is unclear use the Chat link on that page to understand how a support ticket should be opened.

    Regards,

    Shlomi

     

  • Hi Shlomi,

    I tried raising a ticket, it was asking for contract ID. As I have been using the trial version for POC, we don't have the same.

    Could you please let me know how can I proceed further on this.

    Thanks,

    Khaja Shaik.

  • Hi,

    Did you try disabling the standards enforcements as I have suggested earlier?

    If you are in a trial period and would like to get help from HPE support or R&D you need to involve the sales representative who accompany you, he/she will find the way to reach us and promote it. If you are using the community edition and have no intent to decide anytime soon whether or not to purchase the product I am limited to assist only in various forums (such as this one).

    I am pretty sure that if you use Firefox or Chromium this issue will not reproduce.

    Regards,

    Shlomi 

  • Hi Shlomi,

    Thank you for the support. I have tried the same by adding URL to truested sites in my personal laptop, as I am not able to edit IE security preferences in office network laptop. But facing the same issue. I am currently checking with my organization for Contract ID, as we recently took the same.

    However, When the record the same in Chrome code is as follows, please refer to the attached screenshot, Chrome_code.png

    But When change the browser to IE, code will change as below, please refer to the attached screenhshot, IE11_Code.png

    It seems currently some method 'Activate' is not available in IE.

    Could you please have a look once and suggest us.

    Thanks,

    Khaja Shaik.