[Net An. Error Negotiate Client -> Proxy SSL Handshake Failed!!!

I am running into an issue where a script will not record or playback due to an SSL issue in the subject.  I have exhausted a lot of options but can't seem to get it working since the root CA certificate was updated on the puppet server.

I have created a .pem cert and loaded that into port mappings.

I tried all combinations of Socket / Wininet / Socket & Wininet

I have tried different SSL Versions / Ciphers along with the options in port mapping.

I installed the certificate into Personal and Trusted Root CA (along with the server cert)

I ran this file - wplusCAOnly_Expiration_2022.crt

The original cert works fine manually.

I got rid of all expired certs in Personal and Trusted Root CA

I disabled the Firewall

I have LoadRunner version 12.53.

I also found this link - https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/KM01860986?lang=en&cc=us&hpappid=202392_OSP_PRO_HPE

(but that says for 12.50 and older - those .dlls i have are newer than the ones in the support case)

Anything else I missed?

Thanks,
Mark

  • Hello,

    First, as LR is act as middleman when doing the hook recording on SSL traffic, this message(Negotiate Client -> Proxy)   means when AUT client setup the connect with LR recorder, the  SSL Handshake failed. It probably because of the AUT client refused our fabricate certificate. If this is the condition, you can try the option “Use specified proxy-server certificate” in the port mapping settings to present a server certificate to the client.

    Second, we also have two alternative recording method as “Proxy recording” and “Analyze traffic from capture file”,  you can try these two method too.

    Regards,

    Bingle(LoadRunner R&D)

  • Re: Vugen recording issue - Website's security certificate error(Solved)

    I have fixed the issue by doing the following steps.

    1) Go to HP Loadrunner installation Directory -> Bin->Certs

    2) Open each certificate and try to install it in "Local Machine" in the following store " Trusted Root Certification Authoroties". [There could be some invalid certificates which can be ignored.]

    Do the above steps for all the available certificates in Certs folder.

  • Hi,

    I am also facing same issue. Have tried all above mentioned settings but nothing worked.

    Can anyone let me know how can get rid of this issue?

  • Hi,

     

    Currently, I am facing the same issue while recording a script using VuGen . I am using LoadRunner 12.53

    Please let me know the steps to fix.