(LR) Support Tip: Citrix Agent - always use the latest version!

The Citrix Agent is designed as cross-compatible software. This means you can use Citrix Agent 12.02 together

with LR 11.04 or vice versa without any problem.

 

It is recommended to always use the latest version of the Citrix Agent, regardless of the LR version used - e.g. LR 11.52 with Citrix Agent 12.50.

Tags: