No Script is being generated while the recording a native mobile application using android emulator

Hello experts,

I am going to record native mobile application (bank mobile app) and I am using the SDK adnorid emulator and HP Vugen 12.5. I have used the recording Mobile application HTTP/HTML -> Record emulator

During the recording I have just seen the Traffic analysis and I haven’t seen any code are being generated!

 

The output after the recoding has been stopped:

Action()
{

    lr_start_transaction("Login");

    lr_end_transaction("Login",LR_AUTO);

    lr_start_transaction("Request Satement");

    lr_end_transaction("Request Satement",LR_AUTO);
    
    lr_start_transaction("Logout");

    lr_end_transaction("Logout",LR_AUTO);

    return 0;
}

 

 

Output:

****** Start Log Message ******

Web Recorder version : 12.50.1096.0

Recording Mode: HTML-based script

Not recording headers

Not excluding content types

Reset context between actions

Record non-HTML elements in current HTML function

Protocol Type: Multi-Mobile

 

$$$$$$ End Log Message $$$$$$

 

Code generation version: 12.50.1096.0

 

****** Analyze segments filter initialization ******

 

 

So do you have any idea or help on that?

 

Best Regards,

Mohammad

 

Parents Reply
  • Hello Galshadeck,

    thanks for your reply!
    No, I haven't tried to use proxy recording, because the customer doesn't have a proxy on thier application and now I am trying to create the script by using the captured traffic file but Actually I can't see the actual trafic between the Client and the Application servers, the customer using Load Balancer on their environment!
    so, now I am trying to have the pem certificates to complete the generating script!

     

     

    Best Regrads,

    malfaraj

     

Children
No Data