LoadRunner Webservice Soaprequest

 
 

Hi Everyone

I've been having a bit of a battle with load runner 2020 and LR 12.6 in trying to get a successful response to a web service request and tried multiple ways as below 

First: I tried  to import WSDL which have a MTOM Body but getting error that WSDL is not loaded successfully. 

Second : I tried to add a soap request as below but get an internal error below sample of the structure used 

any recommendation 

 

 soap_request("StepName=SOAP Request",                                        
        "URL=http://0.0.0.0:000/example",                                        
        "SOAPEnvelope="
        "<soapenv:Envelope xmlns:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\">"
"<soapenv:Header>"
"<UserMessage>"
"<Message>"
   "<MessageId>d514215-10fd-41c2-8f23-kk6e360bd09e</MessageId>"
"</Message>"
"<Attachment>ID:000</Attachment>"
"</soapenv:Body>"
"</soapenv:Envelope>",                    
        "SOAPAction="                                           
        "ResponseParam=response",                                        
        "Snapshot=t1000002416.inf",    
"UserHandlerName=LrWsAttachmentsHandler",        
        LAST); 

-Also I tried adding request in "SOAPACTION" instead of above  and adding wsdl in SOAPEnvelope section but get same internal error 

Thanks

  • Hi, 

    in add to the suggestion by Fei Gao, can you try a web_rest() or web_custom_request() with a function as below? Pay attention on <wsa:Action> tag: you should found the SOAP schema endpoint with a SoapUI test (view raw, so you can see all the details of your SOAP request). 

    web_rest("Example",
    "URL=http://0.0.0.0:0/example",
    "Method=POST",
    "EncType=raw",
    "Snapshot=t1.inf",
    "Body="
    "<soapenv:Envelope xmlv1:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\">"
    "<soapenv:Header>"
    "<wsa:Action>http://schemas.meniga.com/pathToYourService</wsa:Action>"
    "<v1:Messaging soap:mustUnderstand=\"0\">"
    "<v1:UserMessage>"
    "<v1:MessageInfo>"
    "<v1:MessageId>w2331231-10f0-00xc2-8f23-00e3360bd004</v1:MessageId>"
    "</v1:MessageInfo>"
    "<v1:Info>"
    "<v1:From>"
    ...
    "</soapenv:Header>"
    "<soapenv:Body>"
    ...
    HEADERS,
    "Name=UserHandlerName", "Value=LrWsAttachmentsHandler", ENDHEADER,
    LAST);

    Have a nice day,

    Lorenzo

  • Are you now at LR2020? Have you tried with LR2020SP3?

    Which toolkit are using? .net, axis or wcf?