Vugen 12.5 does not launch browser, fails to record traffic to URL that requires an SSL connection

I am trying to record a simple web htttp/html script to a webserver that requires an SSL (TLS 1.1) connection via port 443. I was able to do this just fine with Loadrunner 12.01 on this same system. However, when I upgraded to Vugen 12..5 (with no patches) the following actions occur I atttempt a recording to this URL. 1) Vugen window minimizes as is normal, 2) the small RECORDING window appears and the elapsed timer starts running and 3) after 60 seconds, Vugen posts a message stating that the application could not be recorded. Continuing the recording at this point does not provide any worthwhile information and so I chose the Cancel Recording option. However, if you look at the Recording outut, there is no log information that is provided. I was hoping for some information indicating some type of SSL Handshake failure but not log information was recorded.

Since I was able to record a script using this same URL with Loadrunner 12.01 within the last week, I am wondering what might be causing this issue and where I need to check in my Vugen configuration for what might be causing this problem. Note that if REPLAY a PREVIOUSLY RECORDED script (done by Vugen 12.01) using Vugen 12.50, the script replays WITHOUT any errors.

So this issue appears to be just a Vugen 12.5 recording and NOT a Vugen 12.5 replaying issue. Any suggestions would be appreciated.

  • Using Proxy recording was also tried, and the same result of not being able to record anything occurs. Also, as before, although the browser process is called by Vugen (as verified by Process Explorer), the browser window (by either ie 11, firefox or chrome) does not even APPEAR. Even trying to record using the basic Winsock protocol fails the same way.

    I also tried a freshly installed Windows 7 Enterprise image on a different system with the same hardware configuration and the same recording problem is occurring. Something is preventing the browser process from displaying its own browser window. Consequently, without a browser window no recording can occur using Winsock or Web- Http/Html protocol.

  • There could be a number of reasons for such behavior. In order for us to investigate this closely, please open a support case.

  • I am encountering similar issue when replaying VUGen script at work place. Please let me know if you happen to resolve or a support ticket opened with HP?


  • I had this problem once, was difficult to investigate as there is no feedback or error ...etc.

    My OS was Windows 7 (64bit). I used some tools and noticed that LR was launching 32 bit Internet Explorer and would just hang. If I directed LR to use the IE 64-bit version via the recording settings (ie: choose your .exe), it would work.


  • Hi,

    Check the Recording Console log for any errors. Some time protocol mismatch may happen and this inturn  creates the problem.

    Sample Error log : 

    Network Analyzer (17f8: 764)] Request Connection: Remote Server @   (Service=)  (Sid=  3)  PROXIED!

    [Network Analyzer (17f8:1b88)]   (Sid:  3) Negotiate Proxy -> Server SSL Handshake (ssl:TLSv1.1, ciphers:AES128-SHA)

    [Net An. Error    (17f8:1b88)]   (Sid:  3) Negotiate Client -> Proxy SSL Handshake Failed!!!

    [Network Analyzer (17f8:104c)]   (Sid:  3) Connection Terminated (by Client)


    Find the attached screen shot to change the SSL protocol settings.



  • Is this issue resolved? I had the same issue after LR12.53 upgrade. It was recording fine on 12.02 version with WinInet capture.

    But since then upgrded to 12.53, Vugen was not able to record any traffic to the server, it invokes the browser but not lunching the application with increasing events so fast on recording bar.

    On the other hand, the previous recorded script on 12.02 threw " Bad Certificate/ SSL handshake failure"  while replaying, i tried adding "SSl_Version" "MAX_CONNECTIONS_PER_HOST" , when I tested SSL connection(recording options -> PortMapping) with the same certificate, successfully negotiate the connection to the server.

    Any help would appreciate in this scenario. Thanks in Advance!



  • Hi,

    Has anyone found solution to this problem?

    I've recently installed a fresh 12.53 Loadrunner (the full package) on Windows 10 Pro and VuGen doesn't launch any of the browser (IE 32-bit, IE 64-bit, Edge and Chrome) when recording.

    I've tried a number of suggestions I've in the forum including disabling DEP, run as administrator, disabling Anti-Virus, re-install LR.  I've also switch LR VuGen logging level to DEBUG but there is no complains about not about to launch browser.

    Any other suggestions would be much appreicated.