There is no data in JMeter graphs in Analysis but can see the passed transactions in the controller


I just tried running one jmeter script in LR controller and I was able to run successfully.

Controller showed the passed transactions which I can not find in the result file.

I have mentioned the JAVA & Jemter paths in environment variables.

Could anyone please let me know If I need to have any additional settings?





  • Hello,

    In the Analysis, go to Tools->Options->Result Collection. 

    In the Data source check "Generate complete data only".

    Afterwards, create a new session using the raw results generated by the controller and check if you can see the JMeter graphs.

    If this doesn't help, check the Controller Output Messages on the bottom side of the Analysis UI and see if there are any errors related to JMeter.

    Best Regards,


  • Thank you for the reply.

    I already checked the output mesages before posting here, there were no messages.

    I tried the option you have suggested but still no use.

    Kindly please let me know is there anything I can do aprat from this.


Reply Children