HPE Loadrunner 12.55 not generating C script for TrueClient protocol


I have a problem at my office with latest version of Loadrunner 12.55. Recently, I was asked to take up LoadTesting for my application. The work is getting transitioned to our team. So, for experiment purpose, I created a Windows Server 2012 sandbox , downloaded Loadrunner 12.55 and installed it. 

My app is a web 2.0 app and I was asked to use Trueclient protocol for recording. So, I selected Trueclient for web and started recording. The tool launched Firefox and I recorded the Login functionality. As I navigate to my application, I see the steps getting recorded in the left pane of the browser. I stopped recording , saved the script and closed the browser. I was taken back to VuGen. But, I don't see the Actions.C getting populated with the trueclient script.

I created another Sandbox with Windows Server 2012 and this time I installed Loadrunner 12.53. It worked on 12.53 and I could see the script generated in 12.53 in Actions.c. 

Can somebody kindly help me with this issue. My guess is Trueclient is not supporting when Loadrunner latest version  is used on Remote Desktop machines. I may be wrong. Any help on this would be highly appreciated.







  • Hi

    can you share a screenshot of what you see in Vugen after you close the TruClient editor?

    what do you mean by action.c? the file itself or the Action block in Vugen?

    can you also share a screenshot of what you see in 12.53 for reference?

    If you are looking for C code (the likes of which you see when you record in web (HTTP / HTML), that is not the case in TruClient and never was, so some clarification would help here :-)



  • Hi Lior

    Thanks for your response.

    I am attaching the screenshots of what I see in Vugen after recording in LR 12.55 and LR 12.53. The first screenshot is from 12.55 where I don't see the script. The second one is from 12.53 which works fine and I do see the script in the Action.C block.

    Yes, I was referring to the action block in vugen

    I was under the impression that the block of code that generates in Action.C file after I record using TrueClient protocol is ANSI C code. Please correct me if I am wrong here.





  • Hi Srinivas,

    Thank you for the clarification..

    TruClient script, when viewed in load mode (i,e, in Vugen directly) is a representation of the recorded steps and not a C code like in web (as you can see in the 12.53 screenshot you added).

    With regards to not seeing the TC script in 12.55 - that is very strange. is this a recurring phenomena? have you tried recording in different browsers (IE or Chromium)? can you try recording another web site in FireFox and let us know if this happens again?