VuGen not invoking Chrome browser - Tried all options provided in older posts

Hello All,

VuGen Version: VuGEN v12.55 Build 0911

Chrome Version: v78 (Latest). 

Protocol: Single - Web HTTP/HTML

I am trying to record a script using Chrome browser. When I click Record button, I get the "Start Recording" options window where I select browser as "Google Chrome" and enter URL and Click Start Recording.

But my Chrome browser is not getting invoked.

I have tried the following options but none of the options work. The AUT is compatible only with Chrome, so I cannot use any other browser to record. Can someone please help in resolving this issue. I tried various search in Google but didn't find any solution to the issue.

1. Uninstalled and Reinstalled Chrome as Admin.

2. Close all chrome browsers/Remove Cache before recording

3. Uninstalled and Reinstalled VuGEN

4. Gave the full path of Chrome.exe and tried to invoke Chrome.


  • Hi Guys,

    I am also getting the same issue and the issue is not with the Vugen version.

    I saw "An exploit attempt was prevented in C:\Program Files (x86)\Google\Chrome\Application\chrome.exe process with PID 11704 and needed to be shut down" error at the timestamp when I started recording, under Event viewer >> Custom Views >> Administrative Events, which means CiscoAmp on my machine is blocking chrome to open.

    You can also write down the timestamp when you started the recording and go to Event viewer and check for the error on that timestamp.

    You can do a couple of things to go, 1) You may uninstall the application which is blocking the chrome to open(in my case that's not an option as it is a mandatory security application), or 2) Try recording script on a machine where CiscoAmp is not present.

    Let me know if it helps.

  • Yes I can confirm this. My organization has already raised a ticket at Cisco and the issue is now for two weeks under its way. Cisco dev team has it reproducible internally. I expect to have a solution in a week time.

    Note that this issue is much more recent than the issue reported 2 years ago. It is triggered by a recent update of Chrome and/or Cisco AMP. Note that also recording with FF is blocked.

    It is sufficient to stop the Cisco AMP for Endpoints Connector during startup of Chrome by VuGen. When Chrome has opened, the service can be started. But the main question is do you get approval for this from your IT department.

  • Here is an update on the fix of Cisco AMP:
    A fix will be available in Exprev Engine 4.13, which will be release with Cisco AMP Connector version 7.4.3.

Reply Children
No Data