Abnormal termination caused by mdrv process.

Hi,

I am running one script(protocol is http/https) with 1000 users. out of that 600 are running properly while 400 are going to failed state giving below error:

1. Abnormal termination  by mdrv process termination

2. Error: Two way communication error: function two_way_comm_post_message/two_way_comm_post_message_ex failed

3. One thread was not created. Parent failed to launch thread

4.Failed to deliever a p2p mesage from parent to child process, reason - communication error

5. an error occcured while calling the MapViewOfFile function. (sys error message: not enough storage is available to process this command)

 

RAM utilization is 15%. CPU utilization is 10%. 

Storage in C=15GB, storage in D=30 GB

I have tried deleting temp file of load runner, tried changing run time setting( run as a process , disabling logs and generate snapshot on error). still no luck so far.

 

please guide

  • Your line 5 error message indicates a Windows resource issue. Are you using/running from a share? Just google on "an error occured while calling the MapViewOfFile function. (sys error message: not enough storage is available to process this command)" and check the *.microsoft.com links.

    You might find the action that is taken by LR by making a trace with procmon.exe (Process Monitor) of sysinternals.com (a miscrosoft webside). You can trace all file access activity of mdrv process. Note: start the trace just after the first 600 users run fine else the log file will be very large.

  • another point i missed, i have another server of same configuration which is able to handle load more than 1000 users. 

  • Are you running the same script with the same runtime settings on both Load Generators? 
    What happens when you run less Vusers on the Load Generator where the issue occurs?

    As I have suggested in the other post you made, please open a support call. I think there is a need to take a process dump and understand better what the scripts are doing.

    Regards,
    Shlomi

  • Yes i am running the same script on both the load generators. When i run 650 U test works fine. 

    as suggested by you, I will take process dump and see whats happening.

     

    Thanks.

  • Hi,

    1. I suggest running less Vusers per LG as long as the issue persist.
    2. Once you have crash dump please share it with me. Send me a private message so I can provide you with further details to share the file
    3. Please open a support ticket. This forum does not replace the formal support process. I suggest progressing on that front as well

    Regards,
    Shlomi