LR/LG 12.02 Agent Process cannot initialize driver

I installed Load Generator to run as a process. After instalation, I cannot run the agent process. I receive this: "MDRV Error: Driver initialization failed, reason - Cannot initialize driver, it went down due to failure or it was released by drv_free. [MERR-10741]" It then tells me that the driver exiting failed because it wasn't initialized.

I am able to have 5 load generators work, all of them are equal. The 6th is exactly the same as those 5, but it is throwing this error. My controller cannot connect to it. I did a fresh uninstall and reinstall of both LG and Loadrunner, but that did not fix the problem.

I am running Windows 7. I have tested it on both Java 7u45 and Java 8u51, neither work. I am running out of ideas.

 

  • Hello Xxsnikrzxx,

    Thank you for your post.

    This issue could be related with a dll which was not registered during the installation.

    For this please open the command prompt as Administrator >> Navigate to the bin folder in the LR installation folder (something like: C:\Program Files (x86)\HP\LoadRunner\bin) and execute the following command:

    regsvr32 logger.dll

    After this, run the scenario again.

  • Hello Daniela,

    I ran the command and a popup came up saying it was successful. I tried to run agent process again and I am still receiving the same error.

    I still cannot connect my Controller to the Load Generator machine because I cannot run Agent Process.

    Thanks.