CCI compilation error when trying to replay truClient script in vugen

Hi,

I have a script I recorded with tru Client.

when I replay it in 'develop script' mode it works fine, but when I replay it in Vugen I get:

Error: CCI compilation error -error: C:\Program Files (x86)\Micro Focus\LoadRunner\bin\cpp.exe: d:\vugen\crm_ramat_gan\\pre_cci.c: Permission denied.
Error: Vuser compilation failed.
Warning: Extension cciext.dll reports error -19800 on call to function ExtPerProcessInitialize
Error: Thread Context: Call to service of the driver failed, reason - thread context wasn't initialized on this thread.

the version I'm using is 12.60 on windows 10.

  • Hello Aviram, 
     
    Hope you are doing great. 
    Have you tried to copy and include the file from the script folder? 

    Also, you have full permissions over Vugen? Have you tried to run it as Administrator? 
     
    Please let us know the outputs after this. 
  • Hi,

    1. "Have you tried to copy and include the file from the script folder? " - I don't understand what you mean. what file?

    2. I am administartor on my machine.

    I want to empasise that the script is running from both "develop mode" as well as from the controller.

     

  • I also face the same problem. I try to go through the WebTours tutorial. But recorded script gives my the error: 

    Error: CCI compilation error -error: C:\Program Files (x86)\Micro Focus\LoadRunner\bin\cpp.exe: c:\temp\loadrunnerscripts\basic_tutorial\\pre_cci.c: Permission denied.
    Error: Vuser compilation failed. Please set CCIDebug to Off in CCI section of mdrv.dat file.
    Warning: Extension cciext.dll reports error -19797 on call to function ExtPerProcessInitialize
    Error: Thread Context: Call to service of the driver failed, reason - thread context wasn't initialized on this thread.

    Can somebody help me to resolve the issue please?

  • Dear Randyross,

     

    I also experience same error when i work with the Webtours sample application. The funny think is once i encounter this error all previously working scripts when re-run give the error  likewise newly developed script give same error. So i am stucked proceeding on any work.

    I have tried adding the olution from the script folder and issue still persist. Also i ran the VuGen as admin and there is still no way forward.

     

    I will appreciate any assistance/suggestion.