TrueClient - Chromium authentication pop up window handling.

Hi!

I use LR 12.53, TruClient - Web protocol (for Chromium).

I test not public Web application within internal network.

I'm recording very simple bussiness logic: Login into the application. While recording, I'm getting "Authentication Required" pop up dialog in which I have to enter user name and password. After recording, I can see my user name and password details in my script.

My script contains 2 steps:

1. "Navigate" step with End Event: "Dialog opened".

2. "Dialog - Authenticate" step with End Event: "Automatic: Action Completed".

But during replay (both in "Develop script" mode and in "Load Replay" mode) the script fails on "Navigate" step.  It tries to navigate to the application URL, the "Authentication Required" pop up dialog appears and the step fails. For some reason, Vugen is not handling this dialog.

I tried to change End Event type to other type but this didn't help. I tried all possible types. While tried to change to "Object Exists" type, I noted that I can't catch any object. Vugen Object Selection Mode can't locate objects at this dialog. 

I asked our developments guys and they said me that this dialog is originated by Chromium and not by an application. This is the reason why Vugen can recognize no objects on this dialog.

Any ideas how to work around this problem will be appreciated.

Thanks in advance.

 

  • Hi,

    Please change the Navigation step end event to "Action Completed", place a wait step after it in case it takes sometime until the authentication dialog appears and then place the "Dialog - Authenticate" step. Let me know how it works. Also, please take a screenshot during replay so we can see where the script hangs and how the application looks like at that time.

    TruClient overrides the browser authentication dialog with its' own implementation. That is done in order to be able to automate this use case. Maybe there is an issue specific to your application which was not observed in common cases.

    Regards,

    Shlomi

     

  • Hi!

    I emplemented your suggestion but this didn't help. Still, the script hangs at the same point: it tries to navigate to the application URL, the "Authentication Required" pop up dialog appears and then the script hangs.

    As I mentioned earlier, I'm testing not public application within internal network, so no snapshots are available.

    Any other ideas?

    Thanks.

  • Hi,

    I might be missing something basic... I will involve more subject matter experts to assist.

    Meanwhile..

    1. Please make sure you work with the latest patch 3 (the latest patch released for 12.53)  I doubt it will resolve this issue, it will just be easier to support you

    2. Open a support ticket

    Regards,

    Shlomi

  • Thanks a lot for your support.

    I'll open a ticket. In parallel, I'll try to install patch 3 and will be waiting for creative ideas from your side.

  • Hi,

    Unfortunately, there are no immediate ideas., We will need to see your application

    Regards,

    Shlomi