Error: lrdo_server_attach: "OCIServerAttach" return-code=OCI_ERROR, error-code=12154:

Hi - i'm getting the following error while replaying the script in vugen 11.51.The same script works fine in vugen 9.52. Below are the vugen client configurations.

 

Vugen 9.52:

win XP SP3

Oracle Client 10.1.0

 

Vugen 11.51

Win 7 SP1

Oracle client 10.1.0.

 

Below is the error message .

vuser_init.c(22): Error: lrdo_server_attach: "OCIServerAttach" return-code=OCI_ERROR, error-code=12154:
vuser_init.c(22): Error:     ORA-12154: TNS:could not resolve the connect identifier specified

 

Any suggestions....

 

Thanks,

vasu

  • Add the \bin directory to the PATH variable

    Adding <Oracle>\bin to the system's PATH variable will allow to access the appropriate database alias to connect to the database. The system environment variables can be changed from the system properties:

    1. Right-click on the My Computer icon on the desktop and select "Properties."
    2. Select the Advanced tab and click on "Environmental Variables."
    3. Under the System Variables section, add <Oracle>\bin to the PATH variable.

    Note: The above changes need to be made both on the VuGen as well as host machines.

  • Thanks  for the reply.

     

    we have Oracle\bin in system path variables.Below is the value for system path variable. we are still seeing the same issue.

     

     

    C:\Oracle\product\10.1.0\Client_1\jre\1.4.2\bin\;C:\Oracle\product\10.1.0\Client_1\jre\1.4.2\bin\client\;C:\Oracle\product\10.1.0\Client_1\BIN\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\strawberry\c\bin;C:\strawberry\perl\bin;C:\Program Files (x86)\HP\Virtual User Generator\strawberry-perl\perl\bin;C:\oracle\product\10.2.0\client_1\BIN\

     

    Thanks,

    vasu

  • Hi Vasu & HP Team,

     

    I have tried recording HP Assest manager application which 2-tier based using Lr12.0 and Oracle 2-tier protocol. While, replaying i got the same error which is mentioned in the text.

     

    I ensured to have the Oracle/Bin folder path to be set in environment variable and but getting getting the error while replaying.

     

    What is the resolution?

     

     

    Thanks,

    Ajit

  • Trying tto run Oracle 2 tire script but seeing below error 

     

    vuser_init.c(18): server_attach: ERROR, return-code=LRDE2089 

    Can some one please explain why i am seeing above error pls