TruClient: No AUT tab is detected


Hi all,

we have a script registered in TruClient-Chromium (version 2021 - R21) and when we launch the test from Controller we have, in some cases, the error message posted below: 

t=02673359ms: Error -205177: No AUT tab is detected. A browser internal tab may be opened.    [MsgId: MERR-205177]

I haven't seen this issue before and I can't find anything about it on the web. 

Can you explain me this particular message? The log doesn't say anything, just the message, and there aren't snapshot that can help me to understand. 

Thanks for your support!

Top Replies

  • 0  


    Is it posssiable to replay in Vugen? open Truclient to replay the script. and if it failed with this error again please attach the snapshot here.

  • 0   in reply to Jason Yu

    Hi Jason and thanks for your interest. 

    I tried many times to replicate the error in VuGen execution, but the same message isn't visible. We have the "No UAT tab is detected" only with Controller execution.

    Have you some other idea?

  • 0   in reply to lb1

    So the Truclient script is fine, is there any possiable that LG went wrong? maybe reinstall it again the error would gone. 

    one more question is there some special steps in this script? or maybe it will pop up some dialog or something? 

  • 0   in reply to Jason Yu

    Hi Jason and thanks for your interest. 

    Effectively, there's some notes and "tutorials" (like post-it on the page, but they are static) on the webpage, and we haven't put checks or clicks on this topics. The particular things is that when a VUser reaches this error message during the test with Controller, then he continues to collect only error messages, like that particular VUser is not available and error counter accumulates failed transactions. 

    Can you give some reason about this behavior?

  • 0  

    We are having the same issue. Anyone find out what is causing it?  I did open a case with MF on this.  So far crickets

  • 0  

    Still going on.  Happens on all LG's.  Even after re-install.  Nobody seems to know what the cause of it is.

  • 0  

    We have also seen this type of error with LR Professional install where it only happens in the Controller. The key fix that we applied was to check the user running the agent.  We found the issue specific to certain users who had enabled to agent on the Load Generator. Also the way the agent was setup (process/service) had an impact.  Required to set as manual login running as a process.

    In saying that, we are now validating LR Cloud and the issue as re-appeared even with the above mentioned resolution in place.

  • 0   in reply to jkrist46

    Hey ,

    we are having the same issue. Did your case with MF get you anywhere?

  • 0   in reply to Conrad Schweizer

    I went no place.  They have no clue.  They told us to trap more errors in steps but that did nothing.  I will be picking it back up once I run it on ELR 2022 r1

  • 0   in reply to jkrist46

    Too bad.

    We tried to run our test with the "TrueClientBrowser" instead of Chromium and we actually no longer had the error message. But TrueClientBrowser is too ressource heavy.