COM/DCOM script generation produces an AccessViolationException error

Hi all,

I am using Loadrunner 12.53 patch 1 to try and record a thick application that is built on DCOM. When I launch the applicaiton from the start recording menu, I can see the number of events increasing (and if I look in the log files later, I can see the events).  However when I stop the script and it tries to create the script I get an error (see attached screenshot). The error is very generic ("System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt") and I have seen lots of instances of it on this forum but not for this particular case. I am looking for some suggestions on how to fix this and get a script generated.

What I have tried so far:

1. Creating an HTTP/HTML script to see if it is just DCOM that has the issue. This script generation worked successfully.

2. Disable DEP and UAC.

3. Creating a winsocks script of this application, this worked successfully.

4. Identified the appropriate library files and added them to the recording options for DCOM.

5. Disabled C parser (this made no difference).

 

I am using LR 12.53 patch 1 on a virtual Windows 2012 R2 running on ESX.

If anyone can think of something I have missed or has any other suggestions please let me know.

 

Many thanks,

Gordon