27792: Failed to connect to server "server:443": [10061] Connection refused

Hello Guys,

I'm having an error message while replaying the VUGen script.

The error occure after this code frame:

 

web_submit_data("acs", 
        "Action=https://{url}/samlsps/acs", 
        "Method=POST", 
        "RecContentType=text/html", 
        "Referer=">iam-authentication-{url}/.../idpSSOInit.jsp
        "Snapshot=t5.inf", 
        "Mode=HTML", 
        ITEMDATA, 
        "Name=SAMLResponse", "Value=PHNhbWxwOlJlc3BvbnNlIHhtbG5zOnNhbWxwPSJ1cm46b2FzaXM6bmFtZXM6dGM6U0FNTDoyLjA6\r\ncHJvdG9jb2wiIElEPSJzMmU4ZGU2MTA2NWJmMzFiODA3M2U0YjY0N2FjYTg1YzAwZWRlZDQwYjMi\r\nIFZlcnNpb249IjIuMCIgSXNzdWVJbnN0YW50PSIyMDE2LTEwLTE4VDEzOjUyOjAxWiIgRGVzdGlu\r\nYXRpb249Im......
LAST);

below is the errco message I'm having:

 

Action.c(78): web_submit_data("acs") started [MsgId: MMSG-26355]
Action.c(78): Redirecting "https://{url}/samlsps/acs" (redirection depth is 0) [MsgId: MMSG-26694]
Action.c(78): To location "https://{server}/samlacserror.html" [MsgId: MMSG-26693]
Action.c(78): Error -27792: Failed to connect to server "{server}:443": [10061] Connection refused [MsgId: MERR-27792]
Action.c(78): Warning -26200: At least one of the resources specified by EXTRARES has not been downloaded due to the above error(s) [MsgId: MWAR-26200]

Could someone help me?

Thanks in advance

Merick

Parents
  • Hello, 

    The error message happens at when LR trying to setup socket connection with remote Server, and [10061] means Server actively refused the connection.  I suppose the request has not been send at this time point, so it should not relate to correlation. 

    May I confirm whether it’s happen on VuGen or LG? And could you check that the URL is accessible forms your VuGen/LG machine, and whether Proxy setting in Runtime settings is correct?

    Regards,

    Bingle(LoadRunner R&D)

  • Hi Bingle,

    I have the same issue. For me, the "Failed to connect to server "ipaddress": [10061] Connection refused" only appears intemittently during the run. 

    - No proxy is used by the application, hence the runtime settings option is set to "no proxy"

    5% of the failed transactions are due to this error.

    Note: I am trying to run 1000 users with 1 load generator. The LG machine has good specs that can sufficiently run the 1k users. 

    Any advise on what might cause this issue? Is it due to Max connections on server or network limitations?(not sure)

Reply
  • Hi Bingle,

    I have the same issue. For me, the "Failed to connect to server "ipaddress": [10061] Connection refused" only appears intemittently during the run. 

    - No proxy is used by the application, hence the runtime settings option is set to "no proxy"

    5% of the failed transactions are due to this error.

    Note: I am trying to run 1000 users with 1 load generator. The LG machine has good specs that can sufficiently run the 1k users. 

    Any advise on what might cause this issue? Is it due to Max connections on server or network limitations?(not sure)

Children
No Data