Error: Vuser failed to initialize extension runlogic.dll

Hi All,

I got an Error when I tried to excute the webservice based recorded script.

Error In Detail:

Error: Run Section does not exist.

Warning: Extension runlogic.dll reports error -15956 on call to function ExtPerThreadInitialize

Error: Vuser failed to initlialize extension runlogic.dll

Vuser Terminated.

Please provide me a solution for this which you can think of.

  • Hi

    Are you running Vugen as an Administrator?

    Do you have full admin privileges on the machine?

    And, this may be a trivial question but still, when you open the Run Logic section in RTS - do you see all in the correct way?

    Thanks,

    Lior

  • Hi Lior,

    Even i am facing getting the same error. I was running my tru-client script and suddenly i started getting error as - Error occured during creation of script metadata : Failed to update script local files info.

    And also my Run logic section in Runtime settings was not correct . Please see the screenshot.

    And 1 more weired thing i observed was Play this step was working fine but play from this step or play entire script was not working.

    I am using LR12.55 version.

    can u plz help me on that. 

    Thanks.

     

  • Hi Vivek,

    My previous questions still stand:

    You say your Runtime setting is incorrect - have you fixed it? added the needed run logic order?

    if you create a new script, does this happen also?

    does this happen in all TC flavors? I mean per each browser you select for recording?

    you say it suddenly started - what has changed in your system?

    does this happen on other machines as well?

    Thanks,

    Lior

  • Hi Lior,

    For new scripts it is not happening but sometimes this error will suddenly pop up resulting in crashing of vugen. I tried this particular corrupted scripts in other machines as well but was getting the same error. It was happening with all the browsers.

    Please check the attched log file if you get any clue.

    Thanks.

  • Hi vivek5,

    The error message: "Error occured during creation of script metadata : Failed to update script local files info." usually indicates that the script is corrupt, one of the script's runtime files is missing, or that access to a file in the script is blocked: another process ifs locking it or it is read-only.

    I'd suggest to try and resolve this issue.

    In case of script corruption, it may be needed to start a new one.

     

    Edo

     

  • Thanks e_Dough for the Reply.

    I know that the script is corrupted but i want to know the reason why this is happening frequently so that i will not repeat the mistake again.

    Rest of all scrips are working fine . The problem is only there with this script. Can it be because of memory issue because i ma running the script from H drive.

    Thanks in advance.