How to have TruClient load connections in parallel?

I am running a TruClient script in develop-mode in LR 12.50. I have noticed, that it seems that when I open a page, the Firefox TruClient add-on waits for every single connection sequentially to finish. So if a given URL tries to make connections to 20 different servers, TruClient wait for each of the connection to finish or to fail. Is that correct?

If so, how can I change this behavior. I want the same behavior as I have with standard-firefox without the add-on installed. When I open an URL which tried to connect to 20 different servers, it does so in parallel. Not all of the page content might be loaded, but enough to continue with the test.

How is that possible to do?

  • Hi,

    TruClient does not change Firefox browser configuration in regards to connections. The browser is configured using the default settings. 

    When working in interactive TruClient UI might slow things down. I suggst you exmaine it when running in load mode in VuGen.

    If you still see an issue please supply a concrete example against a public site and i will investigate it.

    Thanks,

    Shlomi

     

  • Please try the following page:

    https://www.swisscom.ch/de/privatkunden/mobile/devices.html

    when opening this page in a normal browser session, the page is loaded in 2-3 seconds. When opening the exact same page in TruClient it takes much longer. I tried to open the page in TruClient before replying, but STILL I do see a blank white page. Oh wait, now I see some text and images. But it took minutes to load!

    The problem MUST be related to TruClient as part of Loadrunner. It makes it almost impossible to find errors in the script when I run it in VuGen or the Controller...

  • Hi, I tried recording an AJaxTruClient Web script  which just navigates to the mentioned url. So how did it go?

     

    Running Firefox (outside Vugen) towards the URL: less than 10 seconds

    Running the TrueClient script while developing the script (i.e., in the Firefox): less than 10 seconds

    Running it in Vugen after quitting the development Firefox: less than 10 seconds:

    Virtual User Script started at : 2016-05-12 22:49:44
    Starting action Init.
    TruClient Replay for LoadRunner 12.50.0, build 1096. OS: Windows 8.1, Browser: Firefox, initialized on 2016/05/12 at 22:49:39 (0000.000s)
    Ending action Init.
    Running Vuser...
    Starting iteration 1.
    Starting action Action.
    t=00004935ms: ** 1: Navigate to "https://www.swisscom.ch...le/devices.html" ** started [MsgId: MMSG-205180]
    t=00008766ms: ** 1: Navigate to "https://www.swisscom.ch...le/devices.html" ** successfully completed [MsgId: MMSG-205180]
    Ending action Action.
    Ending iteration 1.
    Ending Vuser...
    Starting action End.
    Ending action End.
    Vuser Terminated.

     

     

    This is with Vugen for LoadRunner Community Edition 12.50 patchlevel 3 on a Windows 8.1 laptop,

     

    Given it's reasonably fast for me but not for you, I suggest the problem might be on your side. The good part of that is, it might be some factor you hopefully can adjust. Is it maybe your machine (try Vugen on another machine)? Maybe proxy settings which differ in the two different Firefox browsers? Handling of cache?

     

    Please keep us posted about what you find out!

  •  

    Thanks for the input, maybe it is the proxy settings. But I do not know how to 'copy' the proxy settings from the Normal-Firefox-Browser to the TruClient-Firefox-Browser.

    In the Normal-Firefox-Browse the option "Auto-detect proxy settings for this network" is selected, but it does not seem to exist such an option for the TruClient-Firefox-Browser. Here is a screenshot:


    What to select for the TruClient-Firefox-Browser? Maybe there is a way to set the options directly in the TruClient-Firefox-Browser? I was not able to find an "options" menu entry for the TruClient-Firefox-Browser!

    So how to try this?

  • I also have changed the proxy setting to "No proxy" on both browsers. But I see the same effect.

    With the Normal-Firefox-Browser and "No proxy" the page loads fast.

    With the TruClient-Firefox-Browser and "No proxy" the page takes very, very long.

    What I see has to do something with the TruClient add-on or the used version of firefox. With a different browser on the SAME computer it works just fine.

    Are there other ideas how to fix this problem?

     

  • Hi,

    I'm thinking about the normal list of things to try:

     

    Find a setting which exists in the TC-Firefox and works in the normal Firefox, then using that setting in the TC-firefox?

    Did you try installing VuGen on another computer at work and try the scripting on the new computer?

    Did you try to deinstall VuGen from your machine, then reinstall?

    Are you running the latest version including patches?

     

    Good luck!