VuGen - hidden steps with errors only appearing in Transaction Manager!

Hi there,

I was hoping I could get some help with VuGen, as I’m butchering a previously defined script for use in BPM and I’m having a weird issue.

Basically, as you can see in Screenshot 1, I have 23 steps and four transactions (confusingly 1, 2, 4 and 5) in my script, which is fine.

When I run the script in TruClient, after step 20, I see the error in Screenshot 2.

There’s no Subject textbox in Step 4. It was only by accident when switching transactions, that I found the hidden steps shown in Screenshot 3 - two actions, 4.1 and 4.2, that are listed after the Send action. I have tried deleting the Actions either side of them simultaneously to see if they disappear, but that doesn’t work. They don’t appear in the Script Viewer or in TruClient and I have no way to remove them manually that I can find.

Can anyone help at all? Any assistance is greatly appreciated.


  • Hello David,

    We, TruClient R&D, saw this issue once but we are not sure how to reproduce it. In order to resolve this issue we need to delete the steps from the script file and not from UI.  

    Which version are you using?

    In which LoadRunner version did you create the script intiially? 

    Do you happen to know how the script got into this state? Did you import steps from other script? Did you copy/paste steps inside the same script? Did you import function library? 

    Can you please send me a copy of this script?


    Shlomi (Personal Info Erased)


  • I have the EXACT same problem (and need to fix it).  My script started failing (on a step that has worked correctly for days).  The error message references an object that is not referenced in the current step.  I got the same idea as the OP and checked the Transaction Manager view and sure enough, there are two extra steps (that do NOT appear in Interactive Mode).

    • 88: Click Next
    • 2.1: Mouse down on Limit
    • 2.2: Mouse up on Limit
    • 89: Click Prior Carrier

    I have NO IDEA how 2.1 and 2.2 got there.  They do NOT appear in the Design Mode editor (not even at Step Level 3).  The Limit field isn't even referenced in steps 88 or 89.  Please help me remove Steps 2.1 and 2.2.  Thanks!

  • Hello,

    This issue was resolved in 12.53. 

    12.53 won't fixed existing scripts in which this issue happened but prevent creating additional ones.

    Regarding current corrupted script(s) please open a support call so we can  handle it.




  • Are you sure the script wasn't created intiially in an earlier version and was last editted in 12,.53?

    Please open a support ticket and we will handle.




  • I started this script (new) less than a week ago in VUGen 12.53 and worked with it successfully until it started to fail yesterday. 

    Last night, I managed a workaround [read: hack].  I tried to re-record the problem away, but doing that only pushed the two "ghost" steps to the end of the newly recorded steps.  That gave me the idea to push the two bad steps to the very end of the script and put an "Exit Action" above them.  I was going to re-record those pages, but then got the idea to cut/paste ALL of the (good) steps ABOVE the bad steps and that worked just fine. It's a hack, but it works.

    I attached two images.  The Transaction Editor image shows that the ghosts steps 2.1 and 2.2 appear there., and the VUGen Editor image shows that they do NOT appear there.   NOTE: Before I did the fix above, these ghost steps used to be places between steps 88 and 89.