IE11 Crashing on Vugen 12.53 using WinInet, SSL Error on Sockets

Hi all, Hoping there is a solution for this.

I'm currently trying to record an application using standard WEB/HTTP and run into a few issues. upon trying to authenticate / login to the system.

I've tried a multitude of configuration and other fixes I've found on this forum however none have succeeded so far. Below is what I've tried.

1. WinInet (as well as Sockets & WinINet)  - IE11 crashes, Chrome records no traffic. 

Process: Open home page & click login > There is a problem with your security certificate", page displayed > click Continue anyway > Submit Login credentials, > Crash

Vugen Message: "AUT Process Crashed, Process id: xxxx"

 

2. Sockets - Getting SSL Error (Both IE & Chrome)

Process: Open home Page & Click Login - SSL Error

Vugen Message" The SSL Authentication Failed. Try adjusting the port mapping settings (etc). [Continue] / [Cancel]

Upon contunuing, after about 1 minute there is a standard error page.

Recording log: "[Net An. Error    ( 278: e40)]   (Sid:  4) Negotiate Client -> Proxy SSL Handshake Failed!!!"

[Net An. Error ( c64: 6d0)] SSL_connect(ssl_id = 212746200 = 00000000) Failed, ctx = 0CAE3FD8, err = "[windings symbols], err code = 1576718160
[Net An. Error ( c64: 6d0)] (Sid: 35) SSL handshake with remote server Failed!

 I've also tried disabling auto SSL, or setting it to TLS1.1 & getting the same errors.

And here is everything else I've tried:

  • Changed OpenClientCertificateDialog from 1 to 0 in registery
  • Disabled Data Execution Prevention
  • Disabled UAT
  • Disabled Windows firewall
  • Run VuGen in Admin
  • Checked LR Certificates
  • Tried another machine

 

Now I've run out of ideas and hoping I can get some help

Many Thanks!