NAVIGATION TO ANY PAGE gives me the Authincation error

A SIMPLE NAVIGATION TO ANY PAGE gives me the Authincation error in Vugen (v 12.53 ), doesnt matter if it requires Authentication or not. Recording opens up a page, after I stop and replay it, it will give me Authentication error ..401 unauthorized access etc.  I have gone berserk with this bcoz I have been stuck in that stage for 3 days, no luck or help from anywhere. Why does it requre authentication for every page LR navigates to at the begining. Many a time, I found that Internet Explorerer opens up with "Res://ieframe.dll/dnserror.htm# " error and my AUT browser hangs theren becomes irresponsive. What the heck is this goin on !!!!!  Plz somebody help me out here 

  • Hi,

    In which browser does it happen? 

    Does it happen only when you try to record or regardless also outside VuGen?

    Are you able to navigate in TruClient?

    If it is only in web, can you please try opening the 3 dialogs (Headers, Content Types and Non Resources) in Advanced Recording options and click OK in each. No need to do any changes ( 

    If it does not help can you try the proxy recorder? If the proxy recorder was enabled earlier then do the opposite, disable it and try



  • Thank u very much for ur kind reply, and sorry for my late reply. 

    I guess this problem has something to do with unnecessary traffic sent by chrome browser to googleapi, which has nothing to do with  Web Tour App login business process. Hence, I filtered out traffic for * . I also set "network level interception for any server at port 1080 via trapping" (unchecked) in port mapping. Now after I record a simple business process (log-in ), it plays well without any authication error. 
    At the outset it usually asked for setting web_set_user,  Hence I used " web_set_user("localhost\\jojo", "bean", "localhost:1080");  ( I dont use ANY PROXY) but this didnt work. I also tried web_set_user("MyMachineName\\jojo", "bean", "localhost:1080"); to no avail.

    It happens after I replay ( at runtime ). 

    I can navgate to localhost Web Tour App in  truClient 

    Headers, Content Types and Non Resources are set as u said, but no luck

    As fas as I know "remote application Via LoadRunner proxy " is used for remote Application, but my VuGen and AUT is in the same machine. But I tried it. After I started recording, I changed the proxy settings for firefox and chrome to use Vugen proxy ( localhost:8888) but both browsers DID NOT RECORD ANYTHING. 
    I tried enabling this- recording option>HTTP property>Advance>Use load Runner Proxy to record a local App , which automatically changes the system proxy to LR proxy. It DID NOT WORK EITHER. 

    Although I happened to solve the praimary authentication problem for "login business process" , But if I record another end-to-end process (searching,booking a flight ), it always end up showing an error for Error -27979: Requested form not found [MsgId: MERR-27979] . Do u have any idea how I can master this VuGen Code, I have no idea whatsoever about this descriptive language. I m also not happy with this work-around, bypassing the googleapi domain was not a wishful choice for me. I still wonder why web_set_user("localhost\\jojo", "bean", "localhost:1080"); didnt work


  • Hi,

    Regarding "requested form" error, looks like a correlation issue. 


    As to the "auth" problem, is it also from the book flight demo website?