Recording issue observed with VUGen TruClient (12.50) while login to Salesforce application

Dear HPE Community Members,

There is a recording issue with VuGen TruClient (12.50) while login to the Salesforce application

Steps:

- Open TruClient 'Develop Script' for Firefox browser

- Select a Salesforce application (Lightning experience mode) and start recording

- Type the valid user credential (user id and password) and click on login button

- The Salesforce home page is not loading, hence further steps couldn't get recorded.

Note: There is no any issue observed while navigating similar steps manually. The Salesforce home page get loaded successfully.

Other Required information:  VuGen 12.50, Firefox 47.0.1

Please let me know if any additional information required.

Thanks in advance for the quick response.

Regards,

Shiv

 

  • Hi,

    12.50 was released with an older Firefox version 37.02. Are you sure the firefox version didn't updated by mistake?

    Please note that checking the firefox version from TruClient might trigger an update while TruClient require a specific version of Firefox.

    1. Please copy the firefox folder from <LR/VUEGN>\bin to C::\temp

    2. Check firefox.exe properties under C:\Temp\firefox folder. What is the version?

    3. Open the browser and try to login to Salesforce. Is it successful?

    Regards,

    Shlomi

     

     

  • Hi Shlomi,

    Thanks for your prompt reply.

    I've performed the setps as you mentioned and observed following.

    - Firefox version is 37.0.2

    - Manually navigate the Salesforce application on Firefox 37.0.2 and found error message as below:

    Sorry to Interrupt
    This page has an error. You might just need to refresh it.
    [NoErrorObjectAvailable] UnknownError

    Hence this means, our Salesforce application do not support on Firefox 37.0.2

     

    So, Now I've started recording using IE, but observed an issue with the TruClient. The following information displayed on the TruClient for IE Browser tab:

    Stronger security is required.

    To access this website, enable TLS 1.1 and TLS 1.2.

    Click the  gear icon or the  Tools button near the top-right corner of this window and select "Internet options".

    Click the "Advanced" tab. Scroll down the list and select "Use TLS 1.0", "Use TLS 1.1", and "Use TLS 1.2".

    For additional security, uncheck "Use SSL 2.0" and "Use SSL 3.0". When complete, the window should resemble the following:

     

    I've performed the steps as suggested above, but it didn't work

    Appreciate if you provide the solution for this issue as well.

     

    Thanks in advance

    Shiv

  • Hi,

    I know about other customers who used TruClient Firefox to test Salesforce application using 12.02, hence 12.50 should work as well. I am not sure what is your implementation but Salesforce supports Firefox 37.0.1

    In order to configure TruClient IE you need to open General Settings and select the right TLS settings in the Browser Settings tab. The changes you did in Microsoft IE do not apply on TruClient IE.

    Regards,

    Shlomi

  • Hi,

    I know about other customers who used TruClient Firefox to test Salesforce application using 12.02, hence 12.50 should work as well. I am not sure what is your implementation but Salesforce supports Firefox 37.0.1

    In order to configure TruClient IE you need to open General Settings and select the right TLS settings in the Browser Settings tab. The changes you did in Microsoft IE do not apply on TruClient IE.

    Regards,

    Shlomi

  • Hi Shlomi,

    Thanks for providing the additional information for TruClient IE setup.

    I've tried all the options (SSL3.0, TLS 1.0, TLS 1.1, TLS 1.2) seperately in TruClient General Settings <Browser Settings>, but getting the same message as below for each settings.

    Stronger security is required.

    To access this website, enable TLS 1.1 and TLS 1.2.

    Click the  gear icon or the  Tools button near the top-right corner of this window and select "Internet options".

    Click the "Advanced" tab. Scroll down the list and select "Use TLS 1.0", "Use TLS 1.1", and "Use TLS 1.2".

    For additional security, uncheck "Use SSL 2.0" and "Use SSL 3.0". When complete, the window should resemble the following:

     

    Please suggest other options for the resolution.

    Thanks,

    Shiv

  • Hi,

    Please open support call and HPE support will assist you.

    Regards,

    Shlomi

  • Hi, we have the same issue with LoadRunner v12.53 build 1203.

    We could record using Truclient IE on the TLS1.0-web app. When they change to TLS1.2, we see the message: This page cant be displayed

    Turn on SSL 3.0, TLS 1.0, TLS 1.1 and TLS 1.2 in Advanced settings and try connecting to .....

    In Trueclient IE settings, we try all radio-button options ssl3.0, tls1.0, tls1.1 and tls1.2, but same error message.

  • Note: it works with Truclient Chromium on the same TLS1.2 web, but our requirements is for IE.

  • Hi,

    Can you please install patch 4?  I am pretty sure the fix for this issue was included in it.

    If you cannot install the patch open a support ticket.

    Regards,

    Shlomi

  • Hi Shlomi,

    thanks for the quick rely! The latest LR patch is still 3, released early 2016.

    /t5/LoadRunner-Information-and-News/LoadRunner-12-50-Patch-3-released/td-p/6823429

    Patch 4 is released for UFT only, not for LoadRunner! Please advice if you can find a patch 4 for LoadRunner!