Invalid Security Certificate: LoadRunner is totally unusable!

I am sorry to post my question again, but this issue really is very pressing. I am not able to use LoadRunner at all, it is completly blocked! 

I installed LoadRunner on a Windows 8 machine and tried to record Web-actions (using the "Web - HTTP/HTML"- Protocol) with VuGen 12.50  (proof of concept). But no matter what site I use (e.g. or what browser I use (chrome, firefox, explorer), I ALWAYS get a certificate error: uses an invalid security certificate.

Errorcode: sec_error_unknown_issue


Please see the Screenshot. 

When accessing web pages outside of VuGen (i.e. just open a browser and go), I do not experience any of the issue mentioned above. I am just able to open the website I choose (using chrome, firefox or explorer).

So the problem is clearly associated with LoadRunner! I installed LoadRunner twice; once without a specific certificate, and once with a certificate I create on my own (given the instructions in the LoadRunner User Manual) and used the following steps: 

1. Opened a comand line on windows

2. Changed the directory to where I can find the executables

3. gen_ca_cert -common-name justForTesting

4. gen_ca_cert -install cacert.cer

5. gen_cert -common-name justForTesting

6. gen_cert -install cert.cer

7. Imported the files necessary to continue with the installation of LoadRunner. 


I also tried the following actions so far without any success, without any change of the problem:

1. Change the length of the RSA key as mentioned here:

2. Followed the certificate instructions here:


I really appreciate some help here to get LoadRunner to work !!!


Parents Reply Children