Load Runner - Error: nca_connect_server: cannot communicate with host

I am receiving the following error in my Load Runner Script only when I go to run it as a Load Test:

(Error: nca_connect_server: cannot communicate with host)

I use to know the fix for this and to be honest I can't remember it for the life of me. I want to say it has to deal with adding another function back into my script. Has anyone else had this problem. I am recording using URL mode/HTTP & OracleNCS Protocols. My version of LR is 9.0

Thanks for the respones in advance!

 

 

P.S. This trhead has been moevd from Performance Center Support and News Forum to LoadRunner Support Forum. - hp forum moderator

  • Check out the links to knowledge based articles in this thread:

    http://forums12.itrc.hp.com/service/forums/questionanswer.do?threadId=1207231

    I believe that you need to modify the config file by adding a ServerURL parameter.

    Alan
  • For some reason I am not able to open any of the documents you have linked to in your responses on previous threads for this similar issue.
  • I am also seeing this issue. I am testing and instance of Oracle R12 and I have correlated the icx_ticket and jsessionid items.

    Is there anything else which I need to do in order for the ica_connect_server command to execute properly.
  • There are normally 2 ways of resolving this problem (you may need to do both)

    1) If you receive a message in the log file something like: ifError expired (5) then try: In Runtime Options~Oracle NCA~Client Emulation~Pragma Mode increase the Max retries to 50 (or a few more if required)

    2) You will probably need to Correlate, if you auto-correlate you will probably get an entry something like:

    web_reg_save_param("NCAJServSessionId",
    "LB=",
    "RB=",
    "Search=Noresource",
    LAST);

    and you won't see the parm actually used in the script. However this parm is used by the nca_connect_server command and refers to the default.cfg file to find the name of the parm.

    In most cases a jsessionid is used and you will need to ADD another parm to cope with this e.g.:

    web_reg_save_param("pJID",
    "LB=jsessionid=",
    "RB=",
    "Search=Noresource",
    LAST);

    put this straight after the original parm.

    Then substitite the jsessionid in the following step with the new parm as with any other correlation.

    Hope this helps
    Ray
    (TestingPerformance.co.uk)
  • Did you get solution for this issue? . I am also facing same issue on Oracle 12.0 forms.

     

    Any help will be much appreciated.

  • If you have already tried all the below steps yet facing the issue, also try this: go to the script folder, open up the default.cfg, add the following lines
    [NCA_General]
    NCATimerWaitMode=0
    try replay now.

    Regards,
    AJ
  • I got this to work using a similar approach to what Ray mentioned.

     

    Recording Protocol: Oracle Web App 11i

     

    The script already had this correlation variable for Session ID...so I used it.

     

    ***Correlation Variable***

    web_reg_save_param("NCAJServSessionId",
    "LB=",
    "RB=",
    "Search=Noresource",
    LAST);

     

     

     

    ***BEFORE***

    //    web_url("lservlet;jsessionid=fj9RSpsZswsqnMKyMMjc93fCNDDpB2Wxmfygl30HtmmJnNkF1BgD!-1314234205", 
    //        "URL=https://wfl-prod.web.com/forms/lservlet;jsessionid=fj9RSpsZswsqnMKyMMjc93fCNDDpB2Wxmfygl30HtmmJnNkF1BgD!-1314234205?ifcmd=getinfo&ifhost=APP-29&ifip=169.254.223.237", 
    //        "Resource=0", 
    //        "RecContentType=text/plain", 
    //        "Referer=", 
    //        "Snapshot=t139.inf", 
    //        "UserAgent=Mozilla/4.0 (Windows Server 2008 R2 6.1) Java/1.7.0_21", 
    //        "Mode=HTTP", 
    //        LAST);

     


    ***AFTER***NOTE that you have to use the correlation variable twice***    
            web_url("lservlet;{NCAJServSessionId}", 
            "URL=https://wfl-prod.web.com/forms/lservlet;{NCAJServSessionId}?ifcmd=getinfo&ifhost=APP-29&ifip=169.254.223.237", 
            "Resource=0", 
            "RecContentType=text/plain", 
            "Referer=", 
            "Snapshot=t139.inf", 
            "UserAgent=Mozilla/4.0 (Windows Server 2008 R2 6.1) Java/1.7.0_21", 
            "Mode=HTTP", 
            LAST);

     

  • Thanks Ray........it worked......

    It is very tricky!...

    But you were really great to find it ......!!!!

     

    Many Thanks!

     

  • I found a solution I might share.

    I kept getting Error: nca_connect_server: cannot communicate with host.

    I found it alwsays happened after recording a new action.

     

    After some digging I found that a value gets changed in the default.cfg

    The value

    RelativeURL=/forms/lservlet;jsessionid={NCAJServSessionId}

    was getting changed to:

    RelativeURL={NCAJServSessionId}

     

    I simply changed this back in the default.cfg and replay worked fine!