Citrix ICA protocol will not record .ICA file

Hello,

Vugen 12.02

Citrix Reciever 4.2.100

Win 7 64x

 

Trying to record a Citrix ICA protocol. I've set the recording options to use an .ica file.

 

When I double click on this file my citrix app launches as expected.

 

When I select to Record in Vugen, nothing records. It just sits there. Nothing happens. There is no code generation output.

 

This is our 1st attempt at a Citrix record. Does this issue sound familiar? Any fixes?

  • A bit more information. The only thing I see in the recording log is

     

    [API Trapper ( d18:135c)] Recording in 32-bit mode: C:\Program Files (x86)\HP\Virtual User Generator\Bin\runCitrixClient.exe
    [API Trapper ( dac: 728)] Recording in 32-bit mode: C:\Program Files (x86)\Citrix\ICA Client\wfcrun32.exe

     

     

    However it just stops after those entries and nothing else is recorded.

     

    I tried an older version of Vugen...11.52

     

    It prompted me to install a Citrix registry fix. It then launched a Citrix ICA Client  window that said "Unsupported Function"

     

    The only recorded line was:

     

    "ctrx_set_connect_opt(ICAFILE, "Cscript.ica");"

  • I'm currently having this exact problem.

    On one machine it won't launch a Citrix session when launching from the ICA.

    On the machine next to it it will record without a problem.

     

    Does it record other protocols like web? I notice on my problem machine it doesn't (it launches the browser but doesn't record anything)

     

    I've had Symantecs EndPoint Agent cause problems recording in the past. So you could check for conflicting programs (AV etc)

  • Not sure. I have 3 machines that should all have the same image in terms of anti-virus settings and OS. Not sure what it works on one and not the others.

     

    I tried using an older version of citrix and this worked for the one working machine and but did not for the others.

     

    I noticed off the Protocol Technology Support matrix it says Citrix ICA is not supported for "Native 64bit Clients Recording".

     

    I'm not really sure what that means. Does that mean that is should not work if Vugen is installed on a 64bit OS?

  • Verified Answer

    I did the following and now this is working.  I'm a bit surprised as I thought DEP was already off...

     

    To Disable DEP
    i. In the Elevated Command Prompt, type:
    bcdedit.exe /set {current} nx AlwaysOff
    ii. Restart the computer to apply

  • I had a similar problem and just want to issue a warning.

    Using bcdedit.exe to change DEP settings will trigger Bitlocker TPM.

    This means that you need to have your Bitlocker Recovery key at hand, or disabable Bitlocker before.

    /ola