Citrix Recording Issue - Unsupported Function

Hi,

 

While recording the citrix application, we are encountering “Unsupported Function” message. please find tool details below.

Citrix version -7.5

LoadRunner - 12.02

 

Am looking for a suggestion other than the below mentioned activities which i already tried.

 

  • Before recording, we have killed running wfica32.exe and wfcrun32.exe processes and have also checked that the process do not auto start again.
  • We killed all running citrix related processes in task manager then I tried to record the citrix but no luck.
  • As it is a web citrix based application, we used multi-protocol option and tried with the below different settings in recording options.
    • Recording
      •  HTML based
      •  URL based
    • Configuration
      • Encryption Level – Server Default & 128 Bit
      • Window size – 1024 * 768
    • Mapping-> Capturing Level –>
      • Socket level
      • WinINet level
      • both combination
  • we have also try to record with different Recorder modes like web browser & Windows Application options.
  • Try to recorded with different browsers like Chrome & Internet Explorer.
  • Got one more suggestion like disabling the Antivirus before recording the citrix application.
  • Also tried with below Data Execution Prevention options in control panel settings.
    • Turn on DEP for essential windows programs & services only
    • Turn on DEP for all programs and services except those I select.

Please find the attachment for screenshot.

 

NOTE- Intermittently we are getting snapshot1 pop ups but however we are facing issue as snapshot 2 in the attachment.