Does the IE8 beta patch LR95P118 require upgrading to LR 9.52 first

I have been reading about the LR Beta Patch LR95P118 which is supposed to allow LR 9.5x emulate IE8.

Questions:

1) has anyone tried the patch successfully?

2) does using the patch require upgrading to LR 9.52 first?

3) if you first have to upgrade to LR 9.52 first, is version 9.52 of LR stable?

4) can someone post the LR95PP118 Read Me file to the forum?

Thanks!

Marc Moskovits