Getting UnsupportedClassVersionError: when recording on Flex env

When I try to record the LR9.52 script on Flex environment, I am getting following error:
Description Details:
java.lang.UnsupportedClassVersionError: Bad version number in .class file

Call stack can be found in Code Generation log.
READ/WRITE validation of object failed. The validation process reads and writes the request message using the provided Java classes.

Can anyone help on this?