Intermitted LG failure connecting to Saas Performance Center

Hello
I'm hoping you can help me resolve the following errors. I'm getting these intermittently, and they cause any test running to fall over, and I need to reboot the load generator host from Performance Center, before I can resume.

I have executed the same test at different times, so I believe my scenario is OK. I just cannot seem to find any relevant reason or solution as to why these errors occur, and I therfore don't know how to resolve.

We have other load generators, that are connection OK to the Saas environment, and they run the same versions, and we do not encounter these issues.

Any guidance you could provide would be appreciated.

Errors in LoadRunner_agent_service.log
30/01/2017 16:44:01 Error: Communication error: SSL write error : [param not passed in call]. (sys error message - WSAECONNABORTED) [MsgId: MERR-10343]
30/01/2017 16:44:01 Error: Client almrwcpcmt125-mil5.saas.hpe.com is not responding. [MsgId: MERR-29992]
30/01/2017 16:44:01 Error: Communication error: The Client failed to send packet. The socket has been shut down. [MsgId: MERR-10343]
30/01/2017 16:44:01 Error: Communication error: The Client failed to send packet. The socket has been shut down. [MsgId: MERR-10343]
30/01/2017 16:44:01 Error: Two Way Communication Error: Function two_way_comm_post_message / two_way_comm_post_message_ex failed. [MsgId: MERR-60990]
30/01/2017 16:44:01 Error: Communication error: The Client failed to send packet. The socket has been shut down. [MsgId: MERR-10343]


Errors in RemoteManagement_agent_service.log
30/01/2017 09:46:31 Error: Communication error: The client SSL certificate is not trusted by the server. [MsgId: MERR-10343]
30/01/2017 09:46:31 Error: Two Way Communication Error: Function two_way_comm_resolve_userdata failed. Reason: invalid handle. [MsgId: MERR-60985]
30/01/2017 09:46:31 Error: Communication error: SSL write error : [param not passed in call]. (sys error message - WSAECONNRESET) [MsgId: MERR-10343]
30/01/2017 09:46:31 Error: Communication error: SSL write error : [param not passed in call]. (sys error message - WSAECONNRESET) [MsgId: MERR-10343]
30/01/2017 09:46:31 Error: Communication error: SSL write error : [param not passed in call]. (sys error message - WSAECONNRESET) [MsgId: MERR-10343]
30/01/2017 10:15:44 Error: Two Way Communication Error: Function two_way_comm_resolve_userdata failed. Reason: invalid handle. [MsgId: MERR-60985]
30/01/2017 14:05:40 Error: Communication error: Failed to connect to remote host [server full name: almrwcpcmt125-mil5.saas.hpe.com]. [MsgId: MERR-10343]
30/01/2017 14:05:40 Error: Two Way Communication Error: Function two_way_comm_resolve_userdata failed. Reason: invalid handle. [MsgId: MERR-60985]
30/01/2017 14:05:40 Error: Communication error: Failed to send message - socket is not connected yet. [MsgId: MERR-10343]

Parents
  • Hello ClaireMcG

    Thank you for your post.

    ClaireMcG, I appreciate if you let me know which version of PC do you have?

    Does the script was record on the same version of you currently PC version?

    Please send me a screenshot of the system health check

    Is the script exucted with no errors on vugen?

     

    Please try to reinstall the problematic LG, and let me know if this solves the issue.

  • Daniela, thanks for your response.

    I'm running the following

    Saas based PC = 12.50

    VuGen Version 12.53 Build 1203

    LG - Load Runner Agent Service 12.50.0

    I have executed the same test scenario successfully from PC, and also encountered the errors when running the scenario.  As, it has been successful once, I'm hoping it isn't script and scenario related.

    Any ideas appreciated.

    Thanks

    Claire

  • Hello Claire,

    It seems like there are two different issues here

    1. The original Load Generator connection issue. It is very hard to understand what the issue is. I suggest opening a ticket to get help

    2. Running scripts created in VuGen version x on Load Generator/Controller of versio x-y is not supported. LoadRunner does not support forward compatibility. VuGen version should always be equal or lower than the Load Generator version. The best practice is to use the same version.

    Regards,

    Shlomi

     

Reply
  • Hello Claire,

    It seems like there are two different issues here

    1. The original Load Generator connection issue. It is very hard to understand what the issue is. I suggest opening a ticket to get help

    2. Running scripts created in VuGen version x on Load Generator/Controller of versio x-y is not supported. LoadRunner does not support forward compatibility. VuGen version should always be equal or lower than the Load Generator version. The best practice is to use the same version.

    Regards,

    Shlomi

     

Children
No Data