Unable to connect Perf. Ctr. to ALM using lab management

Trying to add a performance center server (12.2) to ALM lab management (12.2), keeps failing with the following error in the ALM logs, any ideas?

 

com.hp.alm.platform.exception.SetValueException

 

Messages:
handleCreateAction; Failed to create object of type: LAB_SERVERS; com.mercury.td.pcextension.labservice.comm.ILabServiceSetServerPCServiceExceptionDataFaultFaultMessage: Action not authorized: ReconfigureServer; Action not authorized: ReconfigureServer;

 

 

  • Hello.  

    Check Lab Management- PC Servers - ALM Connection.

    Internal and External URL must be http://<server>:<port>/qcbin

    <server> - hostname, not "localhost"

     

    I had same error when trying to add PC Server in Lab Management.

    After changing Internal and External URL in ALM Connection from "">http://localhost/qcbin" to "http://<hostname>/qcbin" PC Server was added successful. 

     

    PC 12.20

  • I have the same issue. I checked the ALM connection URLs and they look correct. I can also access ALM from the PC server.  I've attached my logs from ALM containing the error. Here are the details:

     

    Failed to create object of type: LAB_SERVERS; com.mercury.td.pcextension.labservice.comm.ILabServiceSetServerPCServiceExceptionDataFaultFaultMessage: Action not authorized: ReconfigureServer; Action not authorized: ReconfigureServer;

     

    NOTE: For some reason, HP forums does not allow html files as attachments, even though this is the format that is used by their own logs, so I had to change the extention to .txt.